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1 Einleitung 
Amos (Analysis of MOment Structures) ist ein modernes Werkzeug zur Analyse von Strukturglei-
chungsmodellen mit latenten Variablen. Diesen sehr flexiblen Analyseansatz, häufig auch als Kovari-
anzstrukturanalyse oder Kausalanalyse bezeichnet, kann man in erster Näherung als Kombination von 
Regressions- und Faktorenanalyse begreifen. Viele bekannte statistische Auswertungsverfahren können 
als spezielle Strukturgleichungsanalyse aufgefasst werden (z.B. Regressions-, Varianz-, und Kovarianza-
nalyse). Darüber hinaus stellt die Möglichkeit zur Formulierung von Struktur- bzw. Regressionsgleichun-
gen auf der Ebene latenter Variablen eine sehr attraktive Modellierungsoption dar, die ursprünglich vor 
allem von Karl Jöreskog entwickelt wurde (siehe z.B. Jöreskog & Sörbom 1989). 
Das folgende Beispiel mit einer reziproken Abhängigkeitsbeziehung auf der Ebene latenter Variablen 
demonstriert, welche Flexibilität Amos bei der Formulierung von Strukturgleichungsmodellen bietet: 

ANE
,46

MOTIVAT

,68
ERFOLG

,25

,39

FM

FE

,66
ANE2FANE2 ,81

,71
ANE1FANE1 ,84

,51

ANLAGE,53
ANLAGE2FANL2

,93
ANLAGE1FANL1

,73

,96

UMWELT,62
UMWELT2FUMW 2

,70
UMWELT1FUMW 1

,79

,83

,22

,35

,87
MOTIVAT1 FMOT1,93

,73
MOTIVAT2 FMOT2,85

,82
ERFOLG1 FERF1

,76
ERFOLG2 FERF2

,90

,87

,63

,39

,44

-,35

 
In diesem Kurs können nur Einzelaspekte der Strukturgleichungsmethodologie angesprochen werden. 
Eine ausführliche Behandlung finden Sie z.B. in Bollen (1989). Im Internet sind etliche (meist kürzer 
gehaltene) Darstellungen frei verfügbar, z.B. die URT-Online-Dokumentation zu LISREL 7 (Baltes-Götz 
1994), die Sie von der WWW-Startseite der Universität Trier (http://www.uni-trier.de/) ausgehend fol-
gendermaßen erreichen: 

Weitere Serviceangebote > EDV-Dokumentationen > Elektronische Publikationen > 
Statistische Spezialthemen > Analyse von Strukturgleichungsmodellen mit LISREL 7 

 
Die in diesem Kurs behandelte Amos-Version 5.0 bietet ein umfangreiches Spektrum von Analysetechni-
ken, z.B. die Schätzmethoden 

• Maximum Likelihood (ML), auch bei fehlenden Daten (FIML) 
• ungewichtete (ULS), generalisierte (GLS) und skalenfreie (SLS) kleinste Quadrate 
• asymptotisch verteilungsfreie Schätzer (ADF) 
• Bootstrapping 

Natürlich können auch Daten aus mehreren Populationen simultan analysiert werden. 
 
Seit der Version 5.0 bietet Amos etliche Hilfsmittel zur systematischen Modellsuche, so dass die traditio-
nell eher für konfirmatorische Forschungsbemühungen konzipierte Strukturgleichungsmethodologie nun 
auch in ausgeprägt explorativer Manier zu nutzen ist (z.B. für eine explorative Faktorenanalyse). 
 

http://www.uni-trier.de/�
http://www.uni-trier.de/urt/user/baltes/docs/lisrel/lisrel7.htm�
http://www.uni-trier.de/urt/user/baltes/docs/lisrel/lisrel7.htm�
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Bei aller Methodenvielfalt bemüht sich Amos um Bedienungsfreundlichkeit, wozu nicht zuletzt die Mo-
dellspezifikation durch Aufbau eines Pfaddiagramms beiträgt, das anschließend sogar direkt in Publikati-
onen übernommen werden kann. 
 
Amos 5.0 wird zwar von SPSS vertrieben, ist aber ein selbständiges Windows - Programm, das völlig 
unabhängig von SPSS gestartet und benutzt werden kann. Die Integration in SPSS für Windows besteht 
im Wesentlichen aus zwei Maßnahmen: 

• Amos kann aus SPSS für Windows heraus gestartet werden, wobei die Daten der aktuellen SPSS-
Arbeitsdatei übergeben werden. 

• Amos kann SPSS-Datendateien (Extension: ".sav") einlesen, auch nach einem direkten Start. 
Das Programm bietet neben seiner grafikorientierten Benutzeroberfläche auch die integrierte Makrospra-
che Amos Basic, so dass Arbeitsabläufe gut automatisiert werden können. Schließlich lässt sich Amos als 
ActiveX-Automation Server von anderen Programmen aufrufen. 
 
Der Kurs orientiert sich am sehr empfehlenswerten Handbuch zu Amos 4.0 (Arbuckle & Wothke 1999) 
und der Ergänzung zu Amos 5.0 (Arbuckle 2003), welche die wesentlichen Programmeigenschaften im 
Rahmen mehrerer Auswertungsbeispiele erklären. Im Kurs werden neben Kenntnissen der Strukturglei-
chungsmethodologie auch Erfahrungen mit Umgang mit Windows und mit SPSS für Windows vorausge-
setzt. 
 
Hinweise für LISREL-Anwender 
SPSS hat das früher zur Analyse von Strukturgleichungsmodellen vertriebene Modul LISREL mit fol-
gender Begründung durch AMOS ersetzt: 

"Amos for Windows, developed by Dr. James Arbuckle and published by SmallWaters, Inc. was se-
lected for its superior interface and various tools and functionality. SPSS believes that Amos' interface 
will make these very valuable analytical methods attractive to professionals and statisticians who had 
previously not considered using them." 

Die recht populäre PRELIS/LISREL-Technologie zur Behandlung ordinaler Daten (Polychorische Kor-
relationen und zugehörige Schätzmethoden) hat Amos übrigens noch nicht anzubieten. Zur Rechtferti-
gung wird argumentiert, dass diese Methoden nur in sehr großen Stichproben (≥ 2000) angewendet wer-
den dürften, so dass ein praktischer Nutzen nur selten bestünde. 
 
Hinweis zu Dateien mit Übungsdatensätzen 
Im Kurs werden mehrere Beispiele vorgeführt, die zum Teil auf der WWW-Seite zu diesem Manuskript 
bereitgehalten werden. Ausgehend von der Startseite der Universität Trier (http://www.uni-trier.de/) ist 
diese Webseite folgendermaßen zu erreichen: 

Weitere Serviceangebote > EDV-Dokumentationen > Elektronische Publikationen > 
Statistische Spezialthemen > Analyse von Strukturgleichungsmodellen mit Amos 5.0 

 
Beschränkungen des Manuskripts 
Von den zahlreichen Themen, die in diesem Manuskript überhaupt nicht oder zu knapp behandelt wer-
den, sind besonders zu erwähnen: 

• FIML-Schätzung (Full Information Maximum Likelihood) bei fehlenden Werten 
• Modellierung von Mittelwerten 
• Bootstrapping 
• Modelle mit Interaktionen 

 

http://www.uni-trier.de/�
http://www.uni-trier.de/urt/user/baltes/docs/amos/v50/amos50.htm�
http://www.uni-trier.de/urt/user/baltes/docs/amos/v50/amos50.htm�
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2 Aller Anfang ist leicht 
Auf den URT-Pool-PCs startet man mit 

Start > Programme > SPSS vom NT-Server des URT > Amos > Amos 5.0 Graphics 
die grafikorientierte Amos-Oberfläche, die u.a. eine Zeichenfläche zur Aufnahme des Pfaddiagramms und 
eine Werkzeugpalette bietet: 

 
Mit dem hier abgebildeten, recht komplexen, Modell werden wir uns erst später beschäftigen, wenn die 
technischen Aspekte der Amos-Bedienung geklärt sind. 
 
Bei den ersten Übungsbeispielen kommen Daten aus einer Studie von Attig (1983) zum Einsatz. Hier 
wurden vor und nach einem Gedächtnistraining bei 40 jungen Probanden drei Leistungsmaße erhoben: 

• Erinnerungsleistung (recall1 bzw. recall2) 
• Erinnerungsleistung nach unterstützenden Hinweisen (cued1 bzw. cued2) 
• Erinnerung der richtigen Präsentationsreihenfolge (place1 bzw. place2) 

Außerdem wurden noch weitere Merkmale erfasst: Leistung in einem Vokabeltest, Alter, Geschlecht, 
Ausbildungsniveau. 
Zunächst sollen die Varianzen und Kovarianzen der Variablen recall1, recall2, place1 und place2 ge-
schätzt werden. 
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2.1 Pfaddiagramm zeichnen 
Wir wollen das folgende Pfaddiagramm zeichnen: 

recall1 recall2 place1 place2 

 
Zeichnen Sie zunächst vier Rechtecke für die zu untersuchenden manifesten Variablen auf die Amos-
Zeichenfläche. Das erforderliche Werkzeug erhalten Sie mit 

  oder  Diagram > Draw Observed 

Am besten erzeugen Sie das erste Rechteck, korrigieren dann nötigenfalls dessen Position mit 

  oder  Edit > Move 

und optimieren die Form (Seitenlängen) mit 

  oder  Edit > Shape of Object 

Nun können Sie nach: 

  oder  Edit > Duplicate 

mit Klicken & Ziehen drei Kopien des Rechtecks anfertigen. Wenn Sie dabei die -Taste gedrückt hal-
ten, wird (in Abhängigkeit von der anfänglichen Bewegungsrichtung) die horizontale oder die vertikale 
Koordinate beibehalten. So lassen sich z.B. leicht vier identische Rechtecke erzeugen, die exakt auf glei-
cher Höhe liegen. 
 
Kehren Sie in „Denk- und Ruhephasen“ zur Vermeidung unerwünschter Mauseffekte mit 

  oder  Edit > Select 

zum neutralen Markierungswerkzeug zurück. Selbstverständlich können Sie Missgriffe mit 

  oder  Edit > Undo 

rückgängig machen (mehrstufig). 
 
Wir verknüpfen nun jedes Rechteck mit einer manifesten Variablen, indem wir deren Namen in der Ob-
ject Properties - Dialogbox eintragen, die per Doppelklick auf ein Rechteck oder via Kontextmenü-
Eintrag geöffnet wird, z.B.: 
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Ein Variablenname darf in Amos nahezu beliebig lang sein, wobei ein großer Zeichenvorrat zur Verfü-
gung steht (inklusive Umlauten, Leerzeichen und Zeilenwechsel). Momentan vereinbaren wir Namen für 
beobachtete Variablen, die aus einer Datei importiert werden müssen. An die dort vorhandenen Vari-
ablennamen, die z.B. im Fall von SPSS-Datendateien strengeren Regeln unterliegen, müssen wir uns na-
türlich halten. Wenn dabei ein unschöner Name akzeptiert werden muss, kann dieser in Amos durch ein 
Variable label ergänzt werden, das zumindest im Pfaddiagramm an Stelle des Namens angezeigt wird. 
Markieren Sie bei geöffneter Object Properties - Dialogbox nacheinander die übrigen Rechtecke, um 
auch diese mit Variablennamen (und bei Bedarf auch mit Variable labels) zu versorgen. Beenden Sie 
schließlich die Object Properties - Dialogbox über deren Schließfeld am rechten Rand der Titelzeile. 
 
Momentan beschreibt unser Pfaddiagramm unkorrelierte Variablen: 

recall1 recall2 place1 place2
 

Weil unser Modell aber Kovarianzen erlaubt, müssen wir diese als Doppelpfeile in das Pfaddiagramm 
eintragen. Das erforderliche Werkzeug erhalten Sie mit: 

  oder  Diagram > Draw Covariance 

Tipps: 

• Um einen unteren Bogen zu erhalten, müssen Sie von rechts nach links zeichnen. 
• Mit dem -Werkzeug können Sie die Biegung der Pfeile beeinflussen. 

• Mit dem -Werkzeug können Sie die Pfeilspitzen verschieben. 

• Wenn Sie mit dem Zauberstab  auf das Symbol einer Variablen klicken, werden alle Verbin-

dungspunkte normiert, was in der Regel zu einem attraktiven Ergebnis führt. 
 
Nun sollte Ihr Pfaddiagramm ungefähr die eingangs angegebene Gestalt haben. 
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2.2 Allgemeine Bedienungsmerkmale 

2.2.1 Format der Zeichenfläche ändern und Pfaddiagramm neu einpassen 
Amos startet mit einem portrait-orientierten Layout unter Verwendung der aktuellen Seitengröße des 
Standarddruckers. Nach 

View/Set > Interface Properties 
sind auf dem Registerblatt Page Layout der Dialogbox Interface Properties 

 
alternative Einstellungen möglich, z.B.: 

• Landscape-Orientierung statt Portrait 
• Individuelle Seitengröße 

Mit der vorgegebenen Einstellung (Height = 0, Width = 0) wird die Seitengröße des eingestell-
ten Druckers übernommen. Als maximale Werte akzeptiert Amos jeweils 14 (unabhängig von der 
Maßeinheit), so dass maximal eine Zeichenfläche von 35,56 × 35,56 cm2 möglich ist (bei Ver-
wendung der Maßeinheit Inches). 

 
Weitere Optionen auf dem Registerblatt Page Layout: 

• Frei bleibender Rand um die Zeichnung (Margins) 
• Rahmen auf der Zeichenfläche, wobei Randabstand (Frame) und Dicke (Frame thickness) 

festgelegt werden können 
In obiger Dialogbox wird ein Rahmen mit 0,5 Zoll Randabstand und 5 Pixel Dicke eingezeichnet. 

 
Nach der Änderung des Seitenformats, der Seitenorientierung oder der Ränder kann man das Pfaddia-
gramm mit 

  oder  Edit >Fit to Page 

neu einpassen lassen (siehe unten). 
 



 

AWS.AMOS.3 : 8. Juli 2005 10 
 

Analyse von Strukturgleichungsmodellen mit Amos 5.0 
 

2.2.2 Objekte markieren 
Sie haben folgende Möglichkeiten, Objekte auf der Zeichenfläche für die weitere Bearbeitung zu markie-
ren: 

• Einzelne Objekte markieren 
Schalten Sie mit 

  oder  Edit > Select 

den Markierungsmodus ein und klicken Sie nacheinander auf die gewünschten Objekte. Eine vor-
handene Markierung wird durch einen erneuten Mausklick aufgehoben. 

• Alle Objekte markieren 

  oder  Edit > Select All 

• Alle Markierungen aufheben 

  oder  Edit > Deselect All 

 

2.2.3 Objekte löschen 
Mit 

 oder  Edit > Erase  oder  <Entf> 

wird der Mauszeiger zum Stornierungswerkzeug, das jedes angeklickte Objekt entfernt. 
 

2.2.4 Bearbeitungsschritte rückgängig machen 
Mit 

  oder  Edit > Undo  oder  <Strg>+<Z>  

können Sie bis zu vier Bearbeitungsschritte rückgängig machen. Mit 

  oder  Edit > Redo 

können Sie die zuletzt zurückgenommenen Bearbeitungsschritte wiederherstellen. 
 

2.2.5 Werkzeugpaletten verwenden 
Man kann die Werkzeugpalette (und auch die Menüzeile) per Maus am geriffelten Rand anpacken und an 
einer beliebigen Seite des Amos-Fensters anheften, z.B.: 



 

AWS.AMOS.3 : 8. Juli 2005 11 
 

Analyse von Strukturgleichungsmodellen mit Amos 5.0 
 

 
Nach 

Tools > Customize 
sind mit folgender Dialogbox 

 
etliche Anpassungen der Benutzeroberfläche möglich, z.B.: 

• Werkzeugleisten aus- oder einschalten 
• Werkzeugleisten erstellen oder löschen 
• Bestückung von Werkzeugleisten ändern 

Dazu wählt man auf der Registerkarte Commands eine geeignete Kategorie und transportiert 
per Maus (Ziehen & Ablegen) die Symbole der gewünschten Kommandos auf die Werkzeugleiste. 
Einige recht nützliche Werkzeuge (z.B. zum gleichmäßigen Verteilen markierter Objekte) sind per 
Voreinstellung auf der Standardleiste Amos 5 nicht vertreten und können hier nachgerüstet wer-
den: 
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2.2.6 Speichern, Sicherheitskopien 
Beim Speichern des Pfaddiagramms mit 

File > Save (As)  oder  <Strg><S> 
wird eine Projektdatei mit der Extension .amw angelegt bzw. aktualisiert, z.B.: 

 
Während der Arbeit an einem Projekt entstehen noch weitere Dateien, die bei Gelegenheit vorgestellt 
werden. Alle Dateien zu einem Pfaddiagramm bzw. Modell haben denselben Namensstamm, in unserem 
Beispiel also CovEst. Diese Bezeichnung eignet sich auch für den Ordner, den man der Übersichtlichkeit 
halber für jedes Projekt anlegen sollte. 
 
Amos pflegt Sicherheitskopien mit älteren Versionen der Projektdatei, wobei deren Anzahl (Voreinstel-
lung = 2) über 

View/Set > Interface Properties > Misc 
eingestellt werden kann, z.B.: 

 
In unserem Beispiel heißen die Sicherheitskopien CovEst.bk1, CovEst.bk2, usw. 
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2.2.7 Pfaddiagramme in andere Anwendungen übertragen 
Sie können Amos-Pfaddiagramme ganz einfach via Zwischenablage in andere Anwendungen übertragen, 
z.B. in Microsoft Word 

in Amos: Edit > Copy (to clipboard)  bzw.  <Strg>+<C> 

in Word:  Bearbeiten > Einfügen  bzw.  <Strg>+<V> 
Auf diese Weise sind die obigen Pfaddiagramme in das vorliegende Manuskript gelangt. 
 
Da Amos stets ein komplettes und oft nur mäßig gefülltes „Blatt“ überträgt, müssen Sie im Zielprogramm 
die eingefügte Grafik eventuell beschneiden, in Word 2002 (aus Office XP) z.B. mit Hilfe der Dialogbox 
Grafik formatieren (zu öffnen über den Menübefehl Format > Grafik oder per Kontextmenü zur Gra-
fik): 

 
 
Um ein Pfaddiagramm in Word zu modifizieren, wählt man aus seinem Kontextmenü die Option Bild 
bearbeiten. Durch Verschieben der Begrenzungslinien bietet sich hier eine weitere Möglichkeit, einen 
überdimensionierten Rand zu verkleinern. Im folgenden Beispiel erhielten die „synchronen“ Kovari-
anzpfeile eine Hervorhebung durch Linientyp, -stärke und -farbe: 

 

recall1 recall2 place1 place2 

 
Übrigens bietet auch Amos (über die Object Properties – Dialoge) etliche Möglichkeiten zur optischen 
Gestaltung von Pfaddiagrammelementen (z.B. Farbe, Linienstärke). 
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2.3 Daten einlesen 
Um unser Modell schätzen zu können, benötigt Amos natürlich noch Daten. Es werden zahlreiche Datei-
formate unterstützt: 

• dBase (Versionen 3, 4, 5) 
• Foxpro 
• Lotus 
• Microsoft Excel (ab Version 3) 
• Microsoft Access 
• SPSS 
• Textdateien mit Trennzeichen 

Bei deutschen Windows-Ländereinstellungen ist das Semikolon als Trennzeichen zu verwenden. 
Wir wollen die zum ersten Beispiel gehörigen Daten aus der SPSS-Datei Attg_yng.sav laden, die sich im 
Examples-Unterverzeichnis zum Amos 5 – Programmordner befindet. Nach 

File > Data Files 
erscheint die Dialogbox Data Files: 

 
Deren Schalter File Name öffnet schließlich den Standarddialog zur Dateiauswahl (hier unter Windows 
XP): 
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Nach erfolgreicher Dateizuordnung erlaubt die Data Files - Dialogbox mit dem Schalter View Data 
eine Blick auf die Daten, wobei in unserem Fall die Anzeige von SPSS selbst übernommen wird (, falls 
das Programm auf dem aktuellen Rechner installiert ist). 
 
Wir schließen die Data Files – Dialogbox mit OK und besorgen uns dann mit 

  oder  View/Set > Variables in Dataset 

eine Liste mit den Variablen der geöffneten Datendatei: 

 
Jetzt ist es möglich, im Pfaddiagramm ein Rechteck zu benennen, indem man aus der Liste einen Vari-
ablennamen per Maus packt und auf das Rechteck zieht. Wir hätten also durch frühzeitiges Zuordnen der 
Datendatei lästige Tipparbeit vermeiden können. 
 

2.4 Modellparameter schätzen 
Lassen Sie mit 

  oder  Model-Fit > Calculate Estimates 

die Modellparameter schätzen. Falls bislang noch keine Projektdatei angelegt worden ist, fordert Amos 
nun dazu auf. 
 
Während der (in unserem Beispiel nur sehr kurzen) Rechenzeit werden wir über den Bearbeitungsfort-
schritt informiert. 

 
 

2.4.1 Textergebnisse 
Amos erzeugt eine Ergebnisdatei mit der Namenserweiterung AmosOutput, die nach 

  oder  View/Set > Text Output 

von einem Hilfsprogramm angezeigt wird: 
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Sie besteht aus mehreren Tabellen, die bequem per Navigationszone zu erreichen sind. 
 
Zu vielen Tabellenbestandteilen können per Mausklick ausführliche Erläuterungen abgerufen werden, 
z.B.: 

 
 
Mit dem Symbol  kopiert man eine markierte Tabelle in die Zwischenablage, um sie anschließend in 
eine andere Anwendung zu übernehmen und dort eventuell weiter zu bearbeiten, z.B.: 

Kovarianz Schätzung S.E. C.R. P
recall1 <--> recall2 2,556 1,160 2,203 ,028
place1 <--> place2 17,905 5,225 3,427 ***
recall2 <--> place2 ,427 2,126 ,201 ,841
recall1 <--> place2 3,575 1,902 1,880 ,060
recall1 <--> place1 4,337 2,338 1,855 ,064
recall2 <--> place1 2,014 2,635 ,764 ,445
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Einige weitere Bedienungsmöglichkeiten: 

•  Anzahl der Dezimalstellen wählen 
•  Breite der Spalten einstellen 
•  Gitterlinien aus- bzw. einschalten 

•  Rahmen aus- bzw. einschalten 

•  Hintergrundfarbe für die Tabelle wählen 
•  Hintergrundfarbe für die Kopfzeile der Tabelle wählen 

 
Das Hilfsprogramm für die Ergebnisanzeige lässt sich auch per Amos-Programmmenü (mit Text Out-
put) oder per Doppelklick auf eine AmosOutput-Datei starten. 
 

2.4.2 Erste Ergebnisinterpretationen 
Im Abschnitt Notes for Model > Result der Ergebnisdatei wird mit dem Eintrag 

Minimum was achieved 
signalisiert, dass die Parameterschätzung gelungen ist. Dem Abschnitt Estimates ist u.a. zu entnehmen, 
dass Amos per Voreinstellung bei der Schätzung nach dem Maximum Likelihood - Prinzip arbeitet. 
 
In der Tabelle mit den Kovarianz-Schätzergebnissen (siehe oben) wird zu jedem Schätzwert in der Spalte 
S.E. sein approximativer Standardfehler angegeben, der unter gewissen Voraussetzungen (siehe Ab-
schnitt 3.1) die Konstruktion eines approximativen Vertrauensintervalls erlaubt. Für die Kovarianz von 
recall1 und recall2 erhalten wir z.B. unter Verwendung des 97,5%-Fraktils der Standardnormalverteilung 
(≈ 1,96) das folgende approximative 95%-Vertrauensintervall: 

2 556 1 96 116 2 556 2 274, , , , ,± ⋅ = ±  

 
Neben dem Standardfehler zu einem Schätzwert ist in der mit C.R. (für critical ratio) überschriebenen 
Spalte der folgende Quotient enthalten, der dem aus LISREL bekannten t-Wert entspricht: 

Schätzwert
Standardfehler

 

Mit Hilfe dieses Quotienten lässt sich unter den in Abschnitt 3.1 beschriebenen Verteilungsvoraussetzun-
gen z.B. das folgende Testproblem lösen: 

H0: Kov(recall1, recall2) = 0   versus   H1: Kov(recall1, recall2) ≠ 0 

Bei Gültigkeit der H0 ist der angegebene Quotient eine approximativ, d.h. für N → ∞, standardnormalver-
teilte Zufallsvariable, so dass man bei folgender Entscheidungsregel approximativ einen Test zum Niveau 
α = 0,05 erhält: 

⎪⎩

⎪
⎨
⎧

≤

sonstH

96,1
hlerStandardfe

Schätzwert fallsHfür  ngEntscheidu
1

0  

In unserem Beispiel entscheiden wir uns also für die H1 (C.R. = 2,203). 
 
Um die Testentscheidung durchzuführen, muss man aber nicht unbedingt den kritischen Wert für die CR-
Statistik kennen, da Amos unter dem Spaltentitel P auch die empirischen Überschreitungswahrschein-
lichkeiten für den zweiseitigen Test mitteilt. Die zugehörige Variante der Entscheidungsregel des Tests 
zum Niveau α = 0,05 lautet: 
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⎩
⎨
⎧ ≥

sonstH
05,0P fallsH

für  ngEntscheidu
1

0  

Im Beispiel erhalten wir p = 0,028 und kommen natürlich zur selben Entscheidung wie beim Vergleich 
der CR-Statistik mit dem kritischen Wert 1,96. 
 
Für den eben behandelten approximativen Test, dessen Präzision von der Stichprobengröße abhängt, steht 
bekanntlich mit dem t-Test für Korrelationen eine exakte Alternative zur Verfügung, die natürlich vorzu-
ziehen ist. Die Normalverteilungsvoraussetzung geht in beide Testverfahren ein, beim Amos-Test kommt 
jedoch eine Abhängigkeit von der Stichprobengröße dazu. In vielen Fällen gibt es zum approximativen 
Amos-Test jedoch keine exakte Alternative. 
 

2.4.3 Das Ausgabe-Pfaddiagramm 

Amos kann seine Schätzergebnisse nicht nur in Tabellenform präsentieren, sondern auch in das Pfaddia-

gramm eintragen. Dazu ist nach erfolgreicher Modellschätzung der Schalter  einzurasten. 

Im Beispiel sieht das vervollständigte Pfaddiagramm so aus: 

5,79

recall1

7,94

recall2

33,58

place1

22,16

place2

2,56 2,01 17,91

3,58

4,34 ,43

 
Wer im selbst erstellten Pfaddiagramm die Varianzschätzer ebenso zentriert sehen möchte wie die Ex-
emplare in obiger Abbildung, muss eventuell nach 

  oder  Edit > Move Parameter 

das zuständige Werkzeug verwenden: 

• Bei hinreichender Nähe zum Mauszeiger wird eine Variable rot angezeigt. 
• Dann kann die Parameterposition durch Mausbewegungen bei gedrückter linker Maustaste verän-

dert werden. 
• Analog lassen sich auch die übrigen Parameter in einem Amos-Pfaddiagramm verschieben. 
• Sind mehrere Variablen (oder auch sonstige „Parameterträger“) markiert, gelingt die synchrone 

Veränderung der Parameterpositionen. 
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Bei Anzeige eines Ausgabe-Pfaddiagramms (mit Parameterschätzungen) sind einige Werkzeuge zur Mo-
difikation des Pfaddiagramms nicht verfügbar (z.B. ). Um diese Werkzeuge wieder nutzen zu kön-

nen, muss man erst den Schalter  für den Modellspezifikationsmodus einrasten. 

 

2.5 Optionale Ausgaben 
Nach 

  oder  View/Set > Analysis Properties > Output 

können in der folgenden Dialogbox 

 
noch zahlreiche weitere Ergebnisse angefordert werden, z.B.: 
 
Standardized estimates  
War diese Option bei der Schätzung aktiv, zeigt das Ausgabe-Pfaddiagramm nach dem Markieren der 
zugehörigen Option: 

 
standardisierte Ergebnisse (z.B. Korrelationen statt Kovarianzen): 
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recall1 recall2 place1 place2

,38 ,66

,03

,32

,31

,12

 
 
Sample moments 
Man erhält eine Matrix mit den Stichprobenmomenten, die im Standardfall mit zentrierten Variablen ge-
rade die Varianzen und Kovarianzen enthält. Im Beispiel resultiert die folgende Tabelle mit den schon 
aus dem Pfaddiagramm bekannten Kovarianzen: 

 place2 place1 recall2 recall1 
place2 22,160    
place1 17,905 33,578   
recall2 ,427 2,014 7,944  
recall1 3,575 4,338 2,556 5,788 

 
Implied moments 
Man erhält eine Matrix mit den vom Modell implizierten Momenten, im Standardfall also mit implizier-
ten Varianzen und Kovarianzen. Diese implizierten Varianzen und Kovarianzen unterscheiden sich i.a. 
von den beobachteten, sobald ein Modell Restriktionen enthält (siehe unten). In unserem trivialen Bei-
spiel ohne Restriktionen gibt es allerdings (von Rundungsfehlern abgesehen) keine Unterschiede. 
 

2.6 Modellierung mit Amos Basic 
Amos bietet eine integrierte Makrosprache mit Basic-Syntax und stellt sein gesamtes Leistungsspektrum 
über ein Objektmodell zur Verfügung. Es ist wohl im Wesentlichen an die beiden folgenden Einsatzzwe-
cke gedacht: 

• Modellierung über Gleichungen an Stelle der graphischen Elemente (Rechtecke, Pfeile etc.) 
Dazu dient die Klasse AmosEngine, die wir gleich benutzen werden. 

• Automatisierung von Routinearbeiten mit der graphikorientierten Benutzerschnittstelle 
Dazu dient z.B. die Klasse PathDiagrammer, die in vielen vorgefertigten Makros verwendet 
wird. So steht z.B. in Amos Graphics über 

Tools > Macro > Draw Covariances 
ein Makro bereit, das zu allen markierten exogenen Variablen die möglichen Kovarianzpfeile ein-
trägt und anschließend gleich das -Werkzeug für die meist erforderlichen Nachbesserungen 
aktiviert. Wir werden uns in diesem Kurs nicht damit beschäftigen, Makros zum Automatisieren 
von Amos Graphics zu entwickeln. 

 
Das Automatisierungspotential der Amos-Klassen kann nicht nur für Makros in Amos Basic genutzt wer-
den, sondern auch für Anwendungen in anderen Programmiersprachen. Die umfangreichen Möglichkei-



 

AWS.AMOS.3 : 8. Juli 2005 21 
 

Analyse von Strukturgleichungsmodellen mit Amos 5.0 
 
ten sind im ca. 350 Seiten starken PDF-Dokument Programming Reference beschrieben, das über den 
Documentation-Ordner in der Amos-Programmgruppe anzusprechen ist.1 
Wer keine Erfahrung mit objektorientierter Programmierung hat, muss mit einigem Lernaufwand rechnen 
und sollte vielleicht besser bei der intuitiv bedienbaren Oberfläche von Amos Graphics bleiben. 
 
Die Makro-Programmierumgebung Amos Basic kann über die Amos-Programmgruppe oder aus Amos 
Graphics mit 

Tools > Macro > Basic Editor 
gestartet werden. 
 
Wir wollen ein Amos Basic – Programm erstellen, das die Parameterschätzung in CovEst – Projekt au-
tomatisch ausführt. Nach dem Start der Entwicklungsumgebung wählen wir den Menübefehl 

File > New Engine Program 
und erhalten den folgenden Programmrumpf: 

 
Amos hat schon eine Dim-Anweisung zum Deklarieren der Objektvariablen sem aus der Klasse Amos-
Engine vorgegeben. Das Objekt sem steht für ein Strukturgleichungsmodel und besitzt zahlreiche Me-
thoden, um seine Eigenschaften zu spezifizieren oder seine Leistungen abzurufen. Aufgrund günstig ge-
wählter Voreinstellungen sind für unser Beispiel nur die in folgender Tabelle erläuterten Methodenaufru-
fe erforderlich: 
sem.TextOutput Ein erfolgreicher Amos Basic - Lauf erzeugt die Ergebnisdatei A-

mosScratch.AmosOutput im Windows-Ordner für temporäre Datei-
en. Durch Aufrufen seiner Methode TextOutput teilen wir dem Objekt 
sem mit, dass die Ausgabe automatisch vom zuständigen Hilfspro-
gramm geöffnet werden soll. 

sem.BeginGroup "attg_yng.sav" Die Methode BeginGroup leitet die Modellspezifikation für die erste 
(und hier auch einzige Gruppe) ein und nimmt den Namen der Einga-
bedatei entgegen. Dem Dateinamen müssen Sie eventuell noch eine 
Pfadangabe voranstellen. 

sem.Structure "recall1" 
sem.Structure "recall2" 
sem.Structure "place1" 
sem.Structure "place2" 

Mit der Methode Structure wird das Modell spezifiziert. Im Beispiel 
kann man sich auf die Deklaration der vier Variablen beschränken, 
weil in Amos Basic die zugehörigen Kovarianzen auch ohne explizite 
Angabe in das Modell einbezogen werden. Einträge nach dem Muster 

sem.Structure " recall1 <--> recall1" 
sind also überflüssig. Hier besteht ein Unterschied zu Amos Graphics, 
das bei einem fehlenden Doppelpfeil davon ausgeht, dass Sie die zuge-
hörige Kovarianz auf 0 fixieren wollen. 

                                                 
1 Dies gilt nur für die Amos 5 - Installation auf den Pool-PCs an der Universität Trier. 
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Wenn das fertige Programm 

 
mit 

Makro > Ausführen  oder  <F5> 
gestartet wird, informiert Amos Basic in folgendem Fenster über den Bearbeitungsfortschritt: 

 
Wir erhalten dieselben Ergebnisbestandteile wie mit Amos Graphics (siehe oben). 
 
Es ist nicht möglich, zu einer Modellspezifikation über einen simplen Methodenaufruf ein Pfaddiagramm 
erstellen zu lassen. Zwar kann man die vielfältigen Gestaltungsmöglichkeiten von Amos Graphics auch 
per Programm nutzen, doch erwartet die zuständige Klasse PathDiagrammer dazu präzise Einzelanwei-
sungen. 
 
Beim Speichern eines Makros entsteht eine einfache Textdatei mit der voreingestellten Namenserweite-
rung AmosBasic, die für spätere Zwecke leicht modifiziert oder erweitert werden kann. 
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2.7 Amos aus SPSS starten 
Ist auf einem Rechner neben Amos auch SPSS für Windows installiert, lässt sich das dortige Analysie-
ren-Menü folgendermaßen um einen Eintrag zum Starten von Amos erweitern:1 

• Menübefehl Extras > Menü-Editor 
• Im Menü-Baum ans Ende des Analysieren-Zweigs navigieren und (Ende des Menüs Ana-

ly&sieren) markieren 
• Mausklick auf den Schalter Eintrag einfügen 
• Neuen Eintrag umbenennen (z.B. in Amos 5) 
• Mausklick auf den Schalter Durchsuchen und Datei AmosGraphicsCLI.exe im Amos-

Installationsverzeichnis als auszuführende Anwendung bestimmen 
• Den Programmdateinamen um Kommandozeilenparameter ergänzen, z.B.: 

"C:\Programme\AMOS 5\AmosGraphicsCLI.exe" –ddat –spss %1 
• Übergabe der Daten als SPSS-Datendatei vereinbaren 

Schließlich sollte die Menü-Editor - Dialogbox ungefähr so aussehen: 

 
Um den Amos-Start aus SPSS und die damit verbundene Übernahme der Daten aus der SPSS-
Arbeitsdatei zu üben, beenden wir nötigenfalls Amos, starten SPSS und öffnen dort die Datendatei 
attg_yng.sav mit den oben analysierten Variablen, die sich im Examples-Unterverzeichnis des Amos 5 – 
Programmordners befindet. 
Nun starten wir Amos über den zuvor vereinbarten Menübefehl, z.B.: 

Analysieren > Amos 5 
In Amos angekommen, können wir mit 

  oder  View/Set > Variables in Dataset 

überprüfen, ob wirklich alle Variablen aus der SPSS-Arbeitsdatei zur Verfügung stehen. 
 
SPSS erstellt vor dem Amos-Start eine neue Datei mit dem Inhalt seines Datenfensters in einem Ver-
zeichnis für temporäre Dateien. Amos bezeichnet die übergebene Datei als Working File (Arbeitsdatei), 
wie man über File > Data Files feststellen kann, z.B.: 

                                                 
1 Auf den Pool-PCs an der Universität Trier ist dies bereits geschehen. 
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Nach einem Mausklick auf den Schalter Grouping Variable erfährt man etwas mehr über die Arbeits-
datei: 

 
Mit den Variablen aus der Arbeitsdatei kann die Amos-Analyse genau so ablaufen, wie oben beschrieben. 
Allerdings ist folgendes zu beachten: Sobald wir Amos beenden, wird die von SPSS erstellte Amos-
Arbeitsdatei wieder gelöscht. Sie entsteht wieder neu, wenn wir Amos erneut aus SPSS starten, wobei ihr 
Inhalt dann der aktuellen SPSS-Arbeitsdatei entspricht. Um ein unterbrochenes Amos-Projekt, das Daten 
aus der SPSS- bzw. Amos-Arbeitsdatei benötigt, wieder fortzusetzen, muss man also … 

• die gewünschten Daten in SPSS öffnen und Amos aus SPSS starten 
Dadurch wird Amos gestartet und gleichzeitig dafür gesorgt, dass ein Amos – Working File mit den 
benötigten Daten zur Verfügung steht. 

• die Projektdatei (mit Endung .amw) in Amos öffnen 
Dies geschieht automatisch, wenn es sich um das zuletzt in Amos bearbeitete Projekt handelt. 

Bei dem beschriebenen SPSS-Amos-Kooperationsverfahren besteht m.E. ein gewisses Risiko, irgend-
wann bei einem Amos-Projekt zu landen, dessen Daten unauffindbar sind. Daher erscheint es mir sinnvol-
ler, auf den Amos-Start aus SPSS zu verzichten, Amos statt dessen direkt zu starten und die benötigte 
sav-Datei per 

File > Data Files 
zu öffnen. Amos speichert deren Namen in der Projektdatei und löscht bei der vorgeschlagenen Startme-
thode keinesfalls die analysierten Daten am Ende der Sitzung. 
 
Beim Amos-Start aus SPSS kann es auch leicht zu einer Fehlermeldung wie in folgendem Beispiel kom-
men: 

 
Weil Amos bei jedem Start automatisch das zuletzt bearbeitete Projekt öffnet, kommt zum Konflikt, wenn 
dieses Projekt mit der von SPSS übergebenen Arbeitsdatei nichts anfangen kann.
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3 Modellgültigkeitstests 
Unter Verwendung der Daten aus dem ersten Beispiel (Projekt CovEst.amw) wollen wir den χ2-
Modelltest kennen lernen. Dies ist vielleicht die richtige Stelle, die Verteilungsvoraussetzungen von A-
mos-Modellen anzusprechen. 

3.1 Voraussetzungen für Strukturgleichungsanalysen 
Hypothesentests, Vertrauensintervalle und Effizienzaussagen zu den ML- oder GLS-Schätzmethoden in 
Amos basieren auf folgenden Verteilungsvoraussetzungen: 

• Die Beobachtungen müssen unabhängig voneinander sein. 
• Die gemeinsame Verteilung aller manifesten Variablen muss gewisse Bedingungen erfüllen, die 

z.B. bei multivariater Normalität gegeben sind. 
• Die Kovarianzmatrix der manifesten Variablen muss vollen Rang haben. 

Ein wichtiges Thema bei Verfahren, die auf asymptotischer Statistik beruhen, ist die minimal erforderliche 
Stichprobengröße. In der Literatur (z.B. Backhaus et al. 2003, S. 365; Loehlin 1987, S. 60-61) werden fol-
gende Empfehlungen genannt: 

• Mindestens N ≥ 100, besser N ≥ 200 
• Mindestens N ≥ 5 ⋅ t, wobei t die Anzahl der zu schätzenden Parameter ist. 
• Beim ADF-Schätzverfahren sind noch größere Stichproben erforderlich (m: Anzahl der manifesten 

Variablen): 
min(200; 1,5 ⋅ m ⋅ (m + 1)) 

 
Wenn manifeste exogene Variablen als fixiert betrachtet werden können, genügen schwächere Vertei-
lungsvoraussetzungen: Fixierte Variablen dürfen keinen Messfehler enthalten (siehe Abschnitt 5.1), was 
z.B. bei der von einem Experimentator kontrollierten Gruppenzugehörigkeit erfüllt ist. Die Verteilung der 
fixiertem Variablen ist irrelevant, und für die übrigen Variablen muss gelten (Arbuckle & Wothke 1999, 
S.78): 

• Für jede Wertekombination der fixierten Variablen ist die bedingte gemeinsame Verteilung der 
„zufälligen“ Variablen multivariat normal. 

• Die bedingten Varianz-Kovarianzmatrizen der Zufallsvariablen sind identisch für alle Wertekom-
binationen der fixierten Variablen. 

• Die bedingten Erwartungswerte der Zufallsvariablen hängen linear von den Werten der fixierten 
Variablen ab. 

Diese schwächeren Voraussetzungen sind identisch mit denjenigen der klassischen linearen Regressions-
analyse (vgl. Abschnitt 4). 
 

3.2 Projektdatei öffnen und sichern 
Wenn Sie den Amos-Grafikmodus erneut starten, wird die zuletzt bearbeitete Projektdatei, in unserem 
Fall also CovEst.amw, automatisch geöffnet. Natürlich kann man ein vorhandenes Projekt mit File > 
Open auch explizit aufrufen. 
Damit die Dateien zum ersten Beispiel im aktuellen Zustand erhalten bleiben, sichern wir das aktuelle 
Projekt mit File > Save as in die neue Projektdatei Restrict.amw. 
 

3.3 Parameter-Restriktionen formulieren 
Amos und vergleichbare Programme erlauben eine sehr flexible Formulierung von Hypothesen mit Hilfe 
von Parameter-Restriktionen: 
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• Parameter können auf feste Werte fixiert werden. So lässt sich etwa für einen Parameter β die fol-
gende Nullhypothese prüfen: 

H0: β = 0 

• Zwei oder mehrere Parameter können auf einen identischen (schätzbaren) Wert gesetzt werden. 
So lässt sich etwa für zwei Parameter β1 und β2 die folgende Nullhypothese prüfen: 

H0: β1 = β2 

Um solche Restriktionen in Amos zu formulieren, wechselt man nötigenfalls mit den Schalter  in 

den Modellspezifikationsmodus und öffnet die zuständige Eigenschafts-Dialogbox, z.B. durch Doppel-
klick auf einen betroffenen Parameter (bzw. auf seine graphische Repräsentation im Pfaddiagramm). Nun 
können auf der Parameters-Registerkarte die gewünschten Restriktionen eingetragen werden. 
Im folgenden Beispiel wird die Varianz der Variablen recall1 auf den Wert 6 fixiert: 

 
Amos zeigt die Werte der fixierten Parameter im Modellspezifikations-Pfaddiagramm an, z.B.: 

6

recall1 recall2 place1 place2

 
Um eine Gleichheitsrestriktion zu formulieren, trägt man für alle betroffenen Parameter eine gemeinsame 
symbolische Wertbezeichnung ein, z.B.: 
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Die Bezeichnung ist weitgehend frei wählbar, sollte aber keine „syntaktisch bedeutsame“ Zeichen (z.B. 
Klammern) enthalten. Ferner ist zu beachten, dass in der Amos-Ausgabe die Parameterbezeichnungen 
gelegentlich aus Platzgründen auf minimal sieben Zeichen gekürzt werden. 
Nachdem auf diese Weise in unserem Beispiel die Varianzen der beiden recall-Variablen sowie die Vari-
anzen der beiden place-Variablen gleich gesetzt wurden, sieht das Modellspezifikations-Pfaddiagramm 
folgendermaßen aus: 

v_r

recall1

v_r

recall2

v_p

place1

v_p

place2

 
Auch für Kovarianzen können auf analoge Weise Restriktionen formuliert werden. Im folgenden Modell 
wurde die recall1-place1 - Kovarianz mit der recall2-place2 - Kovarianz gleich gesetzt: 

v_r

recall1

v_r

recall2

v_p

place1

v_p

place2

c_rpc_rp

 
Außerdem wurde das Pfaddiagramm mit den Shape- und Move-Werkzeugen verfeinert (vgl. Abschnitt 
2.1). 
 

3.4 Testung der Parameterrestriktionen 
Nach Anforderung der Schätzung (mit   oder  Model-Fit > Calculate Estimates) erhalten wir in 

der Textausgabe (zu öffnen mit   oder  View/Set > Text Output) u.a. folgende Ergebnisse: 
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Covariances 
   Estimate S.E. C.R. P Label 

place2 <--> recall2 2,712 1,821 1,489 ,136 c_rp 
recall1 <--> place1 2,712 1,821 1,489 ,136 c_rp 
place2 <--> place1 17,149 5,155 3,327 ***  
recall2 <--> place1 2,220 2,216 1,002 ,316  
place2 <--> recall1 4,608 2,166 2,127 ,033  
recall2 <--> recall1 2,872 1,208 2,377 ,017  

Variances 
 Estimate S.E. C.R. P Label 

recall1 7,055 1,217 5,798 *** v_r 
recall2 7,055 1,217 5,798 *** v_r 
place1 27,525 5,177 5,317 *** v_p 
place2 27,525 5,177 5,317 *** v_p  

Bei diesen Tabellen wurden nach der Übertragung von der Amos-Textausgabe in MS-Word kleinere Mo-
difikationen vorgenommen: 

• Löschen überflüssiger Spalten 
• Änderungen bei Breite und Ausrichtung einiger Spalten 

 
In statistischer Hinsicht ist bei den Tabellen zunächst zu beobachten, dass die Gleichheitsrestriktionen zu 
einer Reduktion der Standardfehler in Relation zum unrestringierten Modell geführt haben. 
 
Weil das Modell identifiziert (siehe z.B. Baltes-Götz 1994, S. 2-8) und außerdem die Anzahl der Stich-
probenmomente (im Beispiel: Varianzen und Kovarianzen) größer als die Anzahl der frei schätzbaren 
Parameter ist, kann ein χ2-Modellgültigkeitstest durchgeführt werden, der im Textausgabefenster unter 
Notes for Model folgendermaßen protokolliert wird: 

 

Amos ermittelt für die χ2-Prüfgröße den Wert 6,276, zu dem bei 3 Freiheitsgraden die Überschreitungs-
wahrscheinlichkeit 0,099 gehört. Damit wird bei α = 0,05 die Nullhypothese, also unser Modell mit den 
Parameterrestriktionen, nicht abgelehnt. 
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Weil die Anzahl der Freiheitsgrade, also die Differenz aus der Anzahl der frei schätzbareren Parameter 
und der Anzahl der Stichprobenmomente, für den Modellgültigkeitstest bzw. generell für die Modellbeur-
teilung sehr relevant ist, bietet Amos Graphics mit 

  oder  Model-Fit > Degrees of Freedom 

einen bequemen Zugriff auf die beteiligten Größen. Für unser aktuelles Beispiel erhalten wir: 

 
 

3.5 Beschriftungen und andere Möglichkeiten zur Gestaltung des Pfaddiagramms 
Das eben erfolgreich getestete Model sieht (nach einigen gleich zu besprechenden Nachbearbeitungen) 
im Ausgabe-Pfaddiagramm folgendermaßen aus: 

recall1 recall2

place1 place2

,19,19

,62

,16,33

,41

Modell mit Gleichheitsrestriktionen
(nach Arbuckle & Wothke 1999, Daten aus Attig 1983)

Standardized estimates
(Chi-Quadrat = 6,276, df = 3, p = ,099)  
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3.5.1 Diagrammbeschriftungen 
Gehen Sie folgendermaßen vor, um die in obigem Pfaddiagramm enthaltenen Beschriftungen einzufügen: 

• Bei Anzeige eines Ausgabe-Pfaddiagramms (mit Parameterschätzungen) ist das Beschriftungs-

Werkzeug nicht verfügbar. Wechseln Sie also nötigenfalls mit dem Schalter  in den Modellspezi-

fikationsmodus. 

• Aktivieren Sie das Beschriftungswerkzeug mit: 
   oder  Diagram > Figure Caption 

• Klicken Sie auf eine freie Stelle der Zeichenfläche während der Mauszeiger mit  title  beschriftet ist. 
Daraufhin erscheint die Dialogbox Figure caption. 

• Tragen Sie hier den gewünschten Text ein, wobei u.a. die folgenden Textmakros zur Verfügung ste-
hen, die von Amos beim Zeichnen des Pfaddiagramms durch aktuell gültige Inhalte ersetzt werden: 

Textmakro Es erscheint 
\format
  

„Model Specification“ beim Modellspezifikations-Pfaddiagram, 
„Unstandardized estimates“ oder 
„Standardized estimates“ beim Ausgabe-Pfaddiagramm 

\cmin χ2-Statistik zum Modellgültigkeitstest 
\df Anzahl der Freiheitsgrade im Modellgültigkeitstest 
\p Überschreitungswahrscheinlichkeit zum Modellgültigkeitstest 

Eine vollständige Liste der Amos-Textmakros finden Sie im Hilfesystem über den Indexeintrag Text 
macros. 
Die obige Beschriftung wurde mit folgender Dialogbox erzeugt: 

 
• Beschriftungen lassen sich wie beliebige andere Elemente eines Pfaddiagramms mit dem –

Werkzeug verschieben und mit dem –Werkzeug entfernen. Bei Wahl der Positionierungsoption 

Center on page (siehe unten) ist natürlich nur noch ein vertikales Verschieben möglich. 

• Per –Mausklick kann man im Modellspezifikationsmodus die Dialogbox Figure caption zur 
Modifikation einer vorhandenen Beschriftung öffnen. 
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3.5.2 Formatierungs-Optionen 
Die Dialogbox Interface Properties, die nach 

View/Set > Interface Properties 
erscheint, bietet etliche Optionen zur Formatierung einzelner Ausgabebestandteile, z.B.: 

• Auf dem Registerblatt Typefaces legt man fest, welche Schriftarten in Pfaddiagrammen für Va-
riablennamen, Parameterwerte und Beschriftungen verwendet werden sollen: 

 
• Auf dem Registerblatt Pen Width kann man Linienstärken und Pfeilspitzen verändern. 
• Auf dem Registerblatt Formats kann man die beiden unveränderlichen Formatfamilien Unstan-

dardized estimates und Standardized estimates einsehen sowie zusätzliche Familien defi-
nieren oder ändern. Diese stehen dann als Anzeigevarianten für das Pfaddiagramm zur Verfügung, 
z.B.: 

 
• Die von den Textmakros verwendete Anzahl an Dezimalstellen lässt sich auf der Registerkarte 

Misc einstellen. 
• Über die Optionen der Registerkarte Page Layout wurde oben schon berichtet. 

 

3.6 Parameter-Restriktionen in Amos Basic formulieren 
Mit Hilfe der folgenden Syntaxregeln lassen sich die oben behandelten Parameter-Restriktionen in Amos 
Basic formulieren: 

• Für jede an einer Restriktion beteiligte Kovarianz ist ein Structure-Aufruf erforderlich. Dort setzt 
man zwischen die beiden Variablen einen Kovarianzpfeil, dargestellt durch die Zeichenfolgen 
"<>" oder "<-->" (mit beliebig vielen Bindestrichen). 

• Eine Restriktion wird durch einen in Klammern hinter die Parameterrepräsentation gesetzten Wert 
ausgedrückt. Dabei kann es sich um eine Konstante (bei der Fixierung auf einen festen Wert) oder 
um eine symbolische Wertbezeichnung handeln (bei der Gleichheitsrestriktion). 

Diese etwas abstrakt formulierten Regeln werden in folgendem Beispielprogramm veranschaulicht, das 
die in Abschnitt 3.4 besprochene Textausgabe erzeugt: 
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option explicit 
 
Sub Main 
 Dim sem As New AmosEngine 
 sem.TextOutput 
 sem.BeginGroup "attg_yng.sav" 
 sem.Structure "recall1 (v_r)" 
 sem.Structure "recall2 (v_r)" 
 sem.Structure "place1 (v_p)" 
 sem.Structure "place2 (v_p)" 
 sem.Structure "recall1 <--> place1 (c_rp)" 
 sem.Structure "recall2 <--> place2 (c_rp)" 
End Sub 
 

3.7 Signifikanztests per C.R. oder Parameterrestriktion 
Über den Gültigkeitstest zu einem geeignet restringierten Modell lässt sich natürlich auch ein einzelner 
Parameter auf Signifikanz prüfen. Wir wollen dies für die Kovarianz (bzw. Korrelation) von educatio 
(Anzahl der Ausbildungsjahre) und vocab (Vokalbeltest), zwei andere Variablen aus dem in allen bishe-
rigen Beispielen verwendeten Datensatz, demonstrieren. Beginnen Sie ein neues Projekt, ordnen Sie dem 
selbigen über File > Data Files die Datei attg_yng.sav zu, und erstellen Sie folgendes Pfaddiagramm: 

EDUCATIO VOCAB

 
Statt die Variablennamen umständlich zu tippen, sollten Sie diese per Maus aus der mit 

  oder  View/Set > Variables in Dataset 

aktivierten Liste übernehmen. 
 
Im Pfaddiagramm ist die Kovarianz zwischen den beiden Variablen durch das Fehlen eines entsprechen-
den Pfeils auf 0 fixiert. Fordern wir Amos mit  zur Schätzung der Modelparameter auf, fragt das 
Programm vorsichtshalber nach, ob wir die Fixierung auf 0 ernst meinen oder vielleicht nur einen Pfeil 
vergessen haben: 

 
Daher ist es vielleicht sinnvoller, die Fixierung mit den Methoden aus 3.3 explizit zu formulieren. 
Im Ausgabe-Pfaddiagramm erhalten wir das folgende Resultat: 



 

AWS.AMOS.3 : 8. Juli 2005 33 
 

Analyse von Strukturgleichungsmodellen mit Amos 5.0 
 

1,90

EDUCATIO

73,24

VOCAB

,00
 

Im approximativen χ2-Test wird die Nullhypothese mit p = 0,025 verworfen, wie der Textausgabe zu ent-
nehmen ist: 

Result (Default model) 

Minimum was achieved  
Chi-square = 5,021  
Degrees of freedom = 1  
Probability level = ,025 

Diese Überschreitungswahrscheinlichkeit liegt übrigens trotz der relativ kleinen Stichprobe (N = 40) rela-
tiv nahe beim Ergebnis des exakten t-Tests, der p = 0,028 liefert. 
 
Nun haben wir schon in Abschnitt 2.4.2 eine Möglichkeit kennen gelernt, mit Amos eine Korrelation 
bzw. Kovarianz auf Signifikanz zu testen. Dort wurde der Quotient aus Parameterschätzer und geschätz-
tem Standardfehler als Prüfstatistik verwendet. Für die aktuell betrachteten Variablen gewinnen wir durch 
Aufheben der Parameterrestriktion mit dieser Technik folgendes Ergebnis: 

Covariances: (Group number 1 - Default model) 

Estimate S.E. C.R. PLabel 
EDUCATIO <--> VOCAB 4,100 2,000 2,050 ,040  

Asymptotisch werden die beiden Amos-Testverfahren miteinander und mit dem exakten t-Test überein-
stimmen. Bei einer kleinen Stichprobe wie der unsrigen ist mit Abweichungen zu rechnen, die durchaus 
auch zu unterschiedlichen Testentscheidungen führen können. 
 
Unter den beiden von Amos angebotenen Testverfahren ist im Zweifelsfall das auf dem Likelihood-
Quotienten-Prinzip basierende Verfahren per Parameterrestriktion zu bevorzugen. Dabei muss allerdings 
für jeden zu beurteilenden Parameter ein spezielles eingeschränktes Modell analysiert werden. Wie Sie 
bereits wissen, besteht eine Stärke der Testkonstruktion über Parameterrestriktionen darin, dass sehr fle-
xibel zusammengesetzte Hypothesen formuliert und beurteilt werden können. 
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4 Regressions- und Pfadmodelle für manifeste Variablen 

4.1 Beispiel 
In einer Untersuchung zu den Bedingungen der beruflichen Ambitionen von Jugendlichen (Kerchoff 1974) 
wurden bei 767 Jungen im Alter von 12 Jahren folgende Variablen erhoben:1 
 INTELLNZ Intelligenz des Jungen 
 BLDNGVAT Bildungsgrad des Vaters 
 BERUFVAT Beruf des Vaters 
 SCHULLST Schulleistung des Jungen 
 AMBITION Berufliche Ambitionen des Jungen 
Über das Zusammenwirken der Variablen wird angenommen: 
 SCHULLST = γ11 INTELLNZ + γ12 BLDNGVAT + RS (1) 
 AMBITION = γ21 BERUFVAT + γ22 SCHULLST + RA (2) 
In der ersten Gleichung wird u.a. behauptet, dass eine Erhöhung der Intelligenz um eine Maßeinheit bei Kon-
stanthaltung des väterlichen Bildungsgrades im Mittel zu einer Veränderung der beruflichen Ambitionen um 
γ11 Maßeinheiten führt. Analog sind die übrigen Strukturkoeffizienten zu interpretieren. 
 
Wir beschränken uns zunächst auf die erste Gleichung, erproben Amos also bei einer Aufgabenstellung, 
die auch mit traditioneller Regressionstechnologie zu lösen ist. 
 
Interessierte finden die Kerchoff-Daten in der SPSS-Matrix-Datendatei Ambition.sav (genaue Bezugs-
quelle: siehe Einleitung). 
 

4.2 Einlesen von Momentmatrizen 
Die eben genannte Datei enthält keine Fälle × Variablen - Datenmatrix, sondern eine Korrelationsmatrix 
mit einigen Zusatzinformationen, wie das folgende SPSS-Datenfenster zeigt: 

 
Amos benötigt für die meisten Analysen keine Rohdaten, sondern lediglich die Stichprobenmomente (d.h. 
Mittelwerte, Varianzen und Kovarianzen). Bei einer Regressionsanalyse sind die (unbedingten) Mittel-
werte der Variablen in der Regel nicht von Interesse. 
                                                 
1 Die völlige Fixierung auf väterliche Karrieremerkmale ist wohl der im letzten Jahrtausend noch mangelhaften Emanzipation 

anzulasten. 
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Die Verwendung der (häufig ausschließlich publizierten) Korrelationsmatrix an Stelle der von Amos (und 
vergleichbaren Strukturgleichungsanalyse-Programmen) in der Regel verlangten Kovarianzmatrix ist 
allerdings nur unter folgenden Bedingungen erlaubt, die bei Regressionsmodellen zum Glück erfüllt sind: 

• Das Modell und die Schätzmethode sind skaleninvariant. 
• Das Modell kann die Varianzen der manifesten Variablen perfekt reproduzieren. 

Weitere Informationen zu dem nicht ganz trivialen Problem finden Sie z.B. bei Baltes-Götz (1994, S. 4-
9), Jöreskog & Sörbom (1989, Abschnitt 1.21) und Lee (1985). 
 

4.3 Pfaddiagramme mit gerichteten Pfeilen und latenten Variablen 
Wir wollen die lineare Regression von Schulleistung auf Intelligenz und Bildung des Vaters untersuchen 
und erstellen zunächst das Pfaddiagramm: 

INTELLNZ

BLDNGVAT

SCHULLST RS

 
Beim Zeichnen der drei Rechtecke empfiehlt sich folgende Vorgehensweise: 

• Malen Sie mit -Werkzeug ein Rechteck für den ersten Regressor, und korrigieren Sie seine 

Form bei Bedarf mit dem -Werkzeug. 
Wer an Stelle beliebiger Seitenverhältnisse für Rechtecke und Ellipsen (siehe unten) den goldenen 
Schnitt bevorzugt, befördert über Tools > Customize das -Werkzeug auf die Amos-Palette 
(vgl. Abschnitt 2.2.5) und rastet es vor dem Zeichnen per Mausklick ein. 

• Erzeugen Sie mit -Werkzeug für die restlichen Regressoren Kopien dieses Rechtecks. Halten 
Sie beim Verschieben der Kopie für BLDNGVAT die -Taste fest, damit das Rechteck seine 
horizontale Position behält. 

• Mit  

  oder  Edit > Space Vertically 

können Sie dafür sorgen, dass die drei Rechtecke vertikal gleiche Abstände haben. Das -

Werkzeug muss eventuell über Tools > Customize auf die Standardpalette befördert werden. 
Alternativ können Sie per Customize–Dialog die Drawing-Palette zusätzlich aktivieren, auf der 
sich per Voreinstellung das Ausgleichswerkzeug befindet. 

 
Zeichnen Sie nun mit 

  oder  Diagram > Draw Unobserved 

eine Ellipse für die latente (!) Fehlervariable zum Kriterium. 
 
Um die Y-(Höhen)Koordinate des Kriteriums-Rechtecks auf die zugehörige Fehler-Ellipse zu übertragen, 
aktivieren Sie am besten mit: 
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  oder  Edit > Drag Properties 

den Eigenschaftstransfer, dessen Umfang in folgender Dialogbox festgelegt wird: 

 
Klicken Sie dann auf das Rechteck und ziehen Sie mit gedrückter Maustaste die festgelegten Eigenschaf-
ten auf die Ellipse. 
 
Ergänzen Sie den gerichteten Pfeil für den Effekt der Residualvariablen auf das Kriterium nach 

  oder  Diagram > Draw Path 

ausnahmsweise nachlässig, 

 
und lassen Sie ihn nach 

  oder  Edit > Touch Up 

mit Mausklicks auf Rechteck und Ellipse von Amos in die richtige Position bringen. 
Auf ähnliche Weise lassen sich die gerichteten Pfeile von den Regressoren auf das Kriterium schnell plat-
zieren. 
 
Den Kovarianzpfeil können Sie nach Markieren der beiden exogenen Variablen mit 

Tools > Macro > Draw Covariances 
durch ein vorgefertigtes Amos Basic – Makro automatisch setzen lassen. 
 
Zum bequemen Benennen der manifesten Variablen ordnen wir spätestens jetzt über 

File > Data Files 
dem Projekt seine Eingabedatei zu. Dann öffnen wir mit 

  oder  View/Set > Variables in Dataset 

die folgende Variablenliste 
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und ziehen die benötigten Variablennamen per Maus auf das jeweils zugehörige Rechteck. 
Für die latente Residualvariable müssen wir uns einen Namen ausdenken und dann über die Eigen-
schaftsdialogbox zur Fehler-Ellipse eintragen. 
 

4.4 Ein technisches Identifikationsproblem 
Wenn wir Amos nach obigen Vorarbeiten mit  zur Schätzung der Modellparameter auffordern, bleibt 

nach der Finished-Meldung im Tätigkeitsprotokoll der  - Schalter des Ausgabe-Pfaddiagramms 

passiv, und wir erhalten in der Textausgabe u.a. folgende Informationen: 

 
Mit der in Amos per Voreinstellung frei schätzbaren Varianz der Fehlervariablen enthält das Modell 7 
freie Parameter: 

3 Varianzen: 
INTELLNZ 
BLDNGVAT 
RS 

1 Kovarianz: 
INTELLNZ <--> BLDNGVAT 

3 Strukturkoeffizienten (Pfadgewichte): 
SCHULLST <--- INTELLNZ 
SCHULLST <--- BLDNGVAT 
SCHULLST <--- RS 

Diesen stehen nur 6 Stichprobenmomente gegenüber (3 Varianzen und 3 Kovarianzen), so dass keine 
Identifikation vorliegen kann1. Insbesondere enthält das Modell mit dem Regressionsgewicht der Residu-
alvariablen RS und mit deren Varianz zwei Parameter, die aufgrund der vorhandenen Information nicht 
                                                 
1  Die Tatsache, dass wir an Stelle der Kovarianzmatrix eine Korrelationsmatrix verwenden mussten, ändert nichts an dieser 

Kalkulation. 
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simultan geschätzt werden können. Arbuckle & Wothke (1999, S. 112) illustrieren die Situation mit fol-
gender Analogie: Aus der Mitteilung „Ich habe Eintrittskarten im Wert von 50 € gekauft“ können wir 
nicht simultan die Anzahl der erworbenen Eintrittskarten und den Preis einer einzelnen Karte erschließen. 
Wenn wir aber Anzahl oder Preis kennen, ist der jeweils fehlende Wert leicht zu ermitteln. 
Bei unserem Identifikationsproblem ist allerdings nicht damit zu rechnen, dass wir einen der beiden un-
bekannten Werte irgendwie in Erfahrung bringen. Wir müssen daher einen Parameter fixieren, z.B. das 
Regressionsgewicht auf den Wert 1. 
 
Weil es häufig nötig ist, eine endogene Variable mit einem Fehlerterm zu versorgen und dessen Regressi-
onsgewicht auf 1 zu fixieren, bietet Amos über 

  oder Diagram > Draw Unique Variable 

dazu ein spezielles Werkzeug an. Um es ausprobieren zu können, müssen Sie die bereits vorhandene Feh-
lervariable mit dem  - Werkzeug wieder entfernen. Das  - Werkzeug produziert nach einem 

Klick auf das Kriterium ein kreisförmiges Fehlervariablen-Symbol und lässt dieses Symbol bei weiteren 
Mausklicks um das Kriterium wandern. Nachdem Sie eine angenehme Position gefunden haben, können 
Sie den Kreis bei Bedarf mit dem  - Werkzeug zu einer Ellipse verformen, z.B.: 

 
Die latente Fehlervariable muss auf jeden Fall (per Eigenschaftsdialog) einen Namen erhalten. 
 
Nun steht einer erfolgreichen Schätzung nichts mehr im Weg. Beim Ausgabe-Pfaddiagramm wählen wir 
die standardisierte Variante, weil Amos in diesem Fall den Determinationskoeffizienten der Regressi-
onsgleichung über dem Kriterium notiert: 

INTELLNZ

BLDNGVAT

,35

SCHULLST

,53

,15

,28 RS

 
Ansonsten zeigen die beiden Varianten des Ausgabe-Pfaddiagrams keine relevanten Unterschiede, weil 
wir eine Korrelationsmatrix als Datenbasis verwendet haben. 
 
Wenn Sie in Ihrer Amos-Ausgabe die standardisierten Schätzer und/oder die quadrierte Multiple Korrela-
tion des Kriteriums mit den Regressoren nicht finden, dann müssen Sie deren Ausgabe nach  in der 
Dialogbox Analysis Properties verlangen (vgl. Abschnitt 2.5): 
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Das in diesem Abschnitt gelöste Identifikationsproblem war leicht zu verstehen, und die Lösung ergab 
sich praktisch von selbst. In komplexeren Modellen gibt des durchaus Identifikationsprobleme mit weni-
ger trivialen Ursachen und Lösungen. 
 

4.5 Textausgaben zum Regressionsmodell 
Das eben formulierte Regressionsmodell enthält ebenso viele freie Parameter, wie Stichprobenmomente 
vorhanden sind, und ist außerdem identifiziert, also insgesamt saturiert. In diesem Fall liefert Amos im 
Wesentlichen dieselben Ergebnisse wie Programme zur multiplen linearen Regression, die mit dem OLS-
Schätzverfahren (Ordinary Least Squares) arbeiten. 
In der Textausgabe finden sich u.a. die folgenden Tabellen: 

Notes for Group (Group number 1) 

The model is recursive.  
Sample size = 767 
Maximum Likelihood Estimates 

Regression Weights: (Group number 1 - Default model) 

   Estimate S.E. C.R. P Label 
SCHULLST <--- INTELLNZ ,531 ,030 17,487 ***  
SCHULLST <--- BLDNGVAT ,147 ,030 4,832 ***  

Covariances: (Group number 1 - Default model) 

   Estimate S.E. C.R. P Label 
INTELLNZ <--> BLDNGVAT ,277 ,037 7,388 ***  

Squared Multiple Correlations: (Group number 1 - Default model) 

 Estimate 
SCHULLST ,347  

 
Ein saturiertes Modell impliziert keine Restriktionen für die Kovarianzmatrix der manifesten Variablen, 
so dass auch kein Modellgültigkeitstest möglich ist. 
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Mit der Regressionsprozedur von SPSS 12.0 erhalten wir nahezu identische Ergebnisse: 

Modellzusammenfassung

,589a ,347 ,345 ,8090876
Modell
1

R R-Quadrat
Korrigiertes
R-Quadrat

Standardfehler
des Schätzers

Einflußvariablen : (Konstante), bldngvat, intellnza. 
 

Koeffizientena

,000 ,029 ,000 1,000
,531 ,030 ,531 17,464 ,000
,147 ,030 ,147 4,826 ,000

(Konstante)
intellnz
bldngvat

Modell
1

B Standardfehler

Nicht standardisierte
Koeffizienten

Beta

Standardisierte
Koeffizienten

T Signifikanz

Abhängige Variable: schullsta. 
 

Wir beobachten insbesondere, dass in der sehr großen Kerchoff-Stichprobe (N = 767) die von Amos be-
rechneten Critical Ratios annähernd mit den exakten t-Werten der SPSS-Ausgabe übereinstimmen. 
 

4.6 Pfadanalyse mit Amos 
Das am Anfang von Abschnitt 4 formulierte Modell zu den beruflichen Ambitionen von Jugendlichen 
besteht aus zwei Regressionsgleichungen und behauptet (weniger auffällig), dass die Residualvariablen zu 
den beiden Kriterien unkorreliert seien. Unter diesen Voraussetzungen können alle Parameter mit zwei 
unabhängig voneinander durchgeführten Regressionsanalysen geschätzt und getestet werden, so dass kei-
ne Strukturgleichungs-Technologie benötigt wird. 
Bei der klassischen Regressionsanalyse haben wir aber keine Möglichkeit, die Annahme unabhängiger 
Residuen RS und RA zu überprüfen. Dabei handelt es sich keinesfalls um eine nebensächliche Verein-
barung, sondern um eine handfeste empirische Behauptung. Wir negieren damit z.B. die Existenz von 
exogenen Variablen mit Einfluss auf SCHULLST und AMBITION, die im Modell weggelassen wurden, 
und riskieren verzerrte Schätzungen für den Strukturkoeffizienten γ22, falls wir uns irren. 
Durch seine Fähigkeit, die Annahme unabhängiger Residuen RS und RA zu prüfen, stellt Amos auch 
schon in der recht simplen Situation eines Pfadmodells für manifeste Variablen eine wichtige Ergänzung 
oder Alternative zu den klassischen Analysemethoden dar. 
 
Wir vervollständigen das Pfaddiagramm, tragen den kritischen Kovarianzpfeil ein und vergeben (im Hinblick 
auf eine spätere Restriktion) einen Namen für den zugehörigen Parameter: 
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INTELLNZ

BLDNGVAT

BERUFVAT

SCHULLST

AMBITION

RS
1

RA
1

rc

 
In der Textausgabe interessieren wir uns vor allem für den approximativen Signifikanztest zur Fehlerkovari-
anz: 

Covariances: (Group number 1 - Default model) 

Estimate S.E. C.R. P Label
INTELLNZ <--> BLDNGVAT ,277 ,037 7,388 ***
BLDNGVAT <--> BERUFVAT ,610 ,042 14,430 ***
INTELLNZ <--> BERUFVAT ,250 ,037 6,713 ***
RA <--> RS -,081 ,045 -1,824 ,068 rc 

Zwar liegt das P-Level mit 0,068 nur knapp über der Signifikanzgrenze, doch kam dieses Ergebnis bei 
geringer Effektstärke (Korrelation(RA, RS) = -0,118) hauptsächlich aufgrund der enormen Stichproben-
größe (N = 767) zustande. Daher kann die Nullhypothese unkorrelierter Residuen guten Gewissens bei-
behalten werden. 
 

4.7 Vergleich mehrerer Modelle 
Bei dieser Gelegenheit soll noch demonstriert werden, wie mit Amos bequem mehrere Modelle verglei-
chend untersucht werden können. Nach 

Model Fit > Manage Model 
erscheint die Dialogbox Manage Models: 

 
Hier legen wir mit New ein zusätzliches Modell an, das sich durch Parameterrestriktionen aus dem Stan-
dardmodell ergeben muss. In unserem Beispiel setzen wir die Fehlerkovarianz auf 0, wobei endlich die 
oben vereinbarte Bezeichnung zum Einsatz kommt: 
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Die von Amos vorgegebene Modellbezeichnung kann beliebig geändert werden. 
Nach der nächsten Schätzung mit  können wir per Mausklick auf die Modellbezeichnung zwischen 
zwei Ausgabe-Pfaddiagrammen wählen und die jeweiligen Parameterschätzungen vergleichen: 

 
Aufgrund des oben diskutierten Signifikanztests für die Fehlerkovarianz ist das einfachere Modell zu be-
vorzugen: 

INTELLNZ

BLDNGVAT

BERUFVAT

,35

SCHULLST

,27

AMBITION

,53

,15

,23

,42

RS

RA

,28

,61

,25 ,00

 
Die Textausgabe beschreibt beide Modelle und vergleicht sie außerdem miteinander (siehe Model Com-
parison): 

Nested Model Comparisons 

Assuming model Default model to be correct: 

Model DF CMIN P NFI
Delta-1

IFI
Delta-2

RFI
rho-1

TLI
rho2

Unabhäng. Residuen 1 3,399 ,065 ,003 ,003 ,007 ,007 
Hier finden wir einen Signifikanztest, welcher die Gültigkeit des Modells mit frei schätzbarer Fehlerko-
varianz voraussetzt und prüft, ob das restringierte Modell (mit der auf 0 fixierten Fehlerkovarianz) beibe-
halten werden kann. Er endet wie der verwandte CR-Test (siehe Abschnitt 4.6) mit einer knappen Ent-
scheidung für die Nullhypothese (P-Level = 0,065). Im Allgemeinen können auf diese Weise, also durch 
den Vergleich geschachtelter Modelle, auch mehrere Restriktionen simultan überprüft werden (vgl. Ab-
schnitt 3.7). 
 



 

AWS.AMOS.3 : 8. Juli 2005 43 
 

Analyse von Strukturgleichungsmodellen mit Amos 5.0 
 
In Abschnitt 7 wird mit der so genannten Spezifikationssuche noch eine bequemere Technik zum Ver-
gleich zahlreicher Modelle vorgestellt, die sich speziell für ausgeprägt explorative Forschungsprojekte 
eignet. 
 

4.8 Amos-Analysen aus Visual Basic anfordern 
Die OLE-Automatisierungsklasse AmosEngine kann nicht nur in Amos Basic eingesetzt werden, son-
dern in allen Programmiersprachen, welche die Verwendung von COM-Komponenten unterstützen. In 
diesem Abschnitt wird mit Visual Basic 6.0 ein Programm erstellt, das im Hintergrund von einem Objekt 
aus der Klasse AmosEngine eine Strukturgleichungsanalyse durchführen lässt und dann stolz die Ergeb-
nisse präsentiert, als wären es seine eigenen. 
Sofern auf Ihrem Rechner eine Programmierumgebung für Visual Basic 6.0 (oder höher) vorhanden ist, 
können Sie folgendermaßen vorgehen: 

• Erstellen Sie nach dem Start der Visual Basic - Entwicklungsumgebung ein neues Projekt vom 
Typ Standard-EXE. 

• Löschen Sie das automatisch angelegte Formular über den Projektmanager, weil lediglich die 
Amos-Integration demonstriert und dabei auf ein Benutzer-Interface verzichtet werden soll. 

• Ergänzen Sie über Projekt > Modul hinzufügen > Öffnen ein Quellcode-Fenster und schrei-
ben Sie dorthin das folgende Programm: 

 
Bei der Modellspezifikation via Structure-Methode wird im Beispiel von der Möglichkeit Gebrauch 
gemacht, Gleichungen zu spezifizieren statt einzelner Pfade. 
Die vom Objekt sem angeforderten Ergebnisse werden über die Print-Methode des Debug-Objektes ins 
Direktfenster geschrieben. 
Bevor Sie das Programm starten können, müssen Sie noch über Projekt > Verweise in folgender Dia-
logbox die Klasse Amos Engine verfügbar machen: 
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Nach einer erfolgreichen Ausführung des Programms erscheinen im Direktfenster die Ausgaben der 
Print-Methode. Außerdem wird die Amos-Textausgabe erzeugt und vom zuständigen Hilfsprogramm 
angezeigt. 
Über ein von Visual Basic aus obiger Syntax erzeugtes Exe-Programm lässt sich die spezielle Amos-
Analyse per Doppelklick starten, was etwa bei der regelmäßigen Auswertung von variablen Daten sinn-
voll sein kann. 
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5 Modelle mit latenten Variablen 

5.1 Messfehler und methodologische Gegenmaßnahmen 
In den bisher betrachteten Pfaddiagrammen sind uns latente Variablen nur in der Rolle von Residuen be-
gegnet. Es ist jedoch methodologisch sehr attraktiv, Modelle mit latenten endogenen und exogenen Vari-
ablen zu bilden, um die folgenden, durch messfehlerbehaftete manifeste Variablen bedingten, Probleme 
zu vermeiden (siehe Arbuckle & Wothke 1999, S. 123f): 

• Fehler in den endogenen Variablen führen zu geminderten Determinationskoeffizienten und zu ver-
größerten Standardfehlern der Regressionskoeffizienten. 

• Fehler in den exogenen Variablen mindern die Determinationskoeffizienten und verzerren die Schät-
zungen der Regressionskoeffizienten, wobei die Schätzfehler nicht auf Koeffizienten zu den fehlerhaft 
gemessenen Variablen beschränkt bleiben. 

Um Effekte und Kovarianzen auf der Ebene von latenten, messfehlerfreien Variablen schätzen zu können, 
benötigt man im Allgemeinen für jede latente Variable mindestens zwei manifeste Indikatoren. Diese 
Voraussetzung kann (eventuell mit etwas Aufwand) in der Praxis meist geschaffen werden. 
Bei dem bereits in der Einleitung gezeigten Beispiel1 ist die Bedingung erst recht unproblematisch, weil 
es auf künstlichen Daten basiert: 

ANE MOTIVAT

ERFOLG

FM

FE

ANE2FANE2
1

ANE1FANE1 11

1

ANLAGE
ANLAGE2FANL2

ANLAGE1FANL1

1

11

UMWELT
UMWELT2FUMW 2

UMWELT1FUMW 1

1

11

MOTIVAT1 FMOT11 1

MOTIVAT2 FMOT2
1

1

ERFOLG1 FERF1

ERFOLG2 FERF2

1

1

1

 
Simulationsdaten initiieren eventuell weniger Forschungsdrang, bieten aber den Vorteil, eine Methode 
mit Daten von exakt bekannter Struktur konfrontieren zu können. 
 
Das im Anhang wiedergegebene SPSS-Programm zieht aus einer künstlichen Population mit der in obi-
gem Pfaddiagramm beschriebenen Struktur eine Zufallsstichprobe der Größe N = 384.2 Neben stetigen 
und normalverteilten Indikatoren erzeugt das Programm durch Runden auch „vergröberte“ Varianten mit 
ca. 25 Stufen, um die übliche Messpraxis nachzuempfinden. 
 
Das oben wiedergegebene Pfadmodell beschreibt eine pädagogische „Theorie“ über Leistungsmotivation 
(MOTIVAT) und Schulerfolg (ERFOLG), die in der künstlichen Population perfekt gilt. Zur Erklärung 
werden folgende exogene Variablen herangezogen: 

                                                 
1 Das Pfaddiagramm in der Einleitung enthält die standardisierten Schätzergebnisse. 
2 Interessierte finden den simulierten Datensatz in der Datei mc.sav (genaue Bezugsquelle: siehe Einleitung). 
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• Anspruchsniveau der Eltern (ANE) 
• genetische Ausstattung (ANLAGE) 
• Förderungspotential der Lernumgebung (UMWELT) 

Weil es sich um ein nonrekursives Model mit wechselseitiger Abhängigkeit von Leistungsmotivation und 
Erfolg handelt, sorgt das SPSS-Programm in einer „Zeitschleife“ dafür, dass ein stabiler Zustand aus-
agierter Effekte eingekehrt ist, bevor die „Datenerhebung“ stattfindet. 
 
Wir „forschen“ mit dem korrekten Modell, machen also keine Spezifikationsfehler. Die in obigem Pfad-
diagramm enthaltenen Fixierungen stellen keine empirischen Behauptungen dar, sondern beheben techni-
sche Identifikationsprobleme (vgl. Abschnitt 4.4). 
 

5.2 Weitere Werkzeuge für die Erstellung von Pfaddiagrammen 
Die zur Erstellung eines Pfaddiagramms mit latenten Variablen im Amos-Grafikmodus erforderlichen 
Werkzeuge haben wir im Zusammenhang mit der Residualvariablen bereits kennen gelernt. Amos bietet 
darüber hinaus noch einige Arbeitserleichterungen, die beim Erstellen des obigen Pfaddiagramms sehr 
nützlich sind: 

• Stellen Sie über 
View/Set > Interface Properties > Page Layout > Orientation = Landscape 

nötigenfalls eine querformatige Zeichnungsfläche ein. 

• Zeichen Sie eine Ellipse für das latente Konstrukt ANE. 

• Wählen Sie das Messmodell-Werkzeug mit 

  oder  Diagram > Draw Indicator Variable 

• Klicken Sie dann zweimal auf die Ellipse, um 2 Indikatoren einzeichnen zu lassen: 

1

1 1

 
Amos hat die zum Beheben von technischen Identifikationsproblemen erforderlichen Fixierungen au-
tomatisch vorgenommen. 

• Wählen Sie mit 

  oder   Edit > Rotate 

das Rotationswerkzeug, und klicken Sie so lange auf die ANE-Ellipse, bis die Indikatoren auf der lin-
ken Seite erscheinen: 

11

1

 
• Gehen Sie folgendermaßen vor, wenn Teile des Pfaddiagramms außerhalb der Zeichenfläche liegen: 
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o Alles markieren mit dem -Werkzeug 

o Verschieben mit dem -Werkzeug 

• Verfeinern Sie das Messmodell mit dem -Werkzeug. 

• Ordnen Sie den fünf vorhandenen Variablen ihre Namen zu, um bei Platzproblemen frühzeitig die 
Rechtecke und Ellipsen vergrößern zu können, bevor Sie in die Serienproduktion einsteigen. Statt eine 
Form zu vergrößern kann aber auch die Beschriftung verkleinert werden, z.B.: 

  
Die Namen für die latenten Variablen sind frei wählbar (, soweit keine Namenskonflikte auftreten). 
Um die Namen der manifesten Variablen aus einer Liste übernehmen zu können, sollten Sie spätestens 
jetzt über File > Data Files > File Name die Eingabedatei festlegen. In der Datei mc.sav finden Sie 
die Indikatoren in stetiger (z.B. ANE1S) und in „vergröberter“ Form (z.B. ANE1), wobei in diesem 
Manuskript die vergröberten Varianten eingesetzt werden. 

• Erzeugen Sie mit  für die beiden anderen exogenen Variablen Kopien des (vollständig markier-

ten) Messmodells. Halten Sie beim Verschieben der Kopien die -Taste fest, so dass die Messmodel-
le ihre horizontale Position behalten. 

• Erzeugen Sie einer weiteren Kopie für die erste endogene Variable, vorläufig möglichst weit vom 
rechten Rand der Zeichnungsfläche entfernt. 

• Reflektieren Sie die Indikatoren der endogenen Variablen mit dem -Werkzeug, und bringen Sie 

das Messmodell in die gewünschte Position. 

• Erzeugen Sie mit  eine Kopie für die zweite endogene Variable. 

• Zeichnen Sie mit  je einen Fehlerterm für die endogenen latenten Variablen. 

• Tragen Sie mit  bzw.  die Effekte bzw. Kovarianzen ein. 

Speziell beim Optimieren der Pfeile leistet der Zauberstab  gute Dienste. 

• Sorgen Sie für korrekte Variablennamen. 
Nun sollte Ihr Pfaddiagramm dem oben wiedergegebenen Vorschlag ähneln. 
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5.3 Ergebnisse für Modelle mit latenten Variablen 
Lassen Sie Amos nun die Berechnungen zum fertig spezifizierten Modell ausführen. Es resultieren die 
folgenden (unstandardisierten) Schätzergebnisse: 

6,48
ANE MOTIVAT

ERFOLG

,37

,42

7,67
FM

3,87
FE

ANE2

4,81

FANE2 1,20
1

ANE1

2,70
FANE1 1,001

1

,47
9,51

ANLAGE
ANLAGE2

6,80
FANL2

ANLAGE1

,74
FANL1

,89
1

1,001

6,47
UMWELT

UMWELT2

4,68
FUMW 2

UMWELT1

2,82
FUMW 1

1,08
1

1,001

,25

,48

MOTIVAT1

2,18
FMOT11,00 1

MOTIVAT2

4,49

FMOT2,92
1

1

ERFOLG1

2,72
FERF1

ERFOLG2

3,80

FERF2

1

1

1,00

,98

4,10

3,06

3,48

-1,93

 
Wie es bei der Überprüfung eines korrekten Modells zu erwarten ist, kommt der χ2-Gültigkeitstest zu 
einem günstigen Ergebnis (P-Level = 0,64): 

Notes for Model (Default model) 

Computation of degrees of freedom (Default model) 

Number of distinct sample moments: 55
Number of distinct parameters to be estimated: 29

Degrees of freedom (55 - 29): 26
Result (Default model) 

Minimum was achieved  
Chi-square = 22,867  
Degrees of freedom = 26  
Probability level = ,640 

In einem nonrekursiven Modell interessiert auch der Stabilitätsindex, der betragsmäßig kleiner als 1 sein 
muss: 

Notes for Group/Model (Group number 1 - Default model) 

Stability index for the following variables is ,200 
           ERFOLG 
           MOTIVAT 

 
Wie ein Vergleich mit dem datengenerierenden SPSS-Programm zeigt, entsprechen die geschätzten Mo-
dellparameter recht gut den wahren Populationswerten. Dies gilt auch für die Reliabilitäten, die im Pfad-
diagramm mit den standardisierten Schätzergebnissen (siehe Einleitung) über den Indikatoren eingetra-
gen sind. 
 



 

AWS.AMOS.3 : 8. Juli 2005 49 
 

Analyse von Strukturgleichungsmodellen mit Amos 5.0 
 
Es liegt nahe, zu Vergleichszwecken auch die Ergebnisse einer rein manifesten Forschungsmethodologie 
zu betrachten. Verwendet man an Stelle der latenten Variablen jeweils den ersten Indikator, ergibt sich 
das folgende Ausgabe-Pfaddiagramm mit unstandardisierten Schätzergebnissen: 

9,19

ANE1

10,25

ANLAGE1

9,29

UMWELT1

MOTIVAT1

ERFOLG1

,17

,19

,22

,83 ,54

3,37

3,02

4,16

10,56

FM
1

10,03

FE

-8,70

1

 
Wir erhalten zwar ein vergleichbares Ergebnismuster, doch sind viele Schätzungen deutlich verzerrt. 
 
Es ist allerdings unfair, Schätzungen auf der Basis von jeweils zwei Indikatoren pro Konstrukt mit Schät-
zungen auf der Basis der „halben“ Information zu vergleichen. Verwendet man an Stelle des ersten Indi-
kators jeweils die Summe aus beiden Indikatoren, resultieren folgende Ergebnisse: 

38,94

ANE12

41,57

ANLAGE12

35,42

UMWELT12

MOTIVA12

ERFOLG12

,24

,21

,30

,66 ,48

13,82

12,57

18,63

35,76

FM
1

27,80

FE

-21,32

1

 
Durch diese Testverlängerung und die damit verbundene Reliabilitätssteigerung gewinnt die manifeste 
Schätzmethodologie erheblich an Präzision, bleibt aber der latenten Methodologie unterlegen, wie die 
folgende Tabelle (mit unstandardisierten Schätzergebnissen) zeigt: 

Parameter Wahrer 
Wert 

Schätzer für 
latente Variablen 

Schätzer für mani-
feste Variablen 

(Summe der Ind.) 

Schätzer für mani-
feste Variablen 

(erster Indikator) 
MOTIVAT  ANE 0,3 0,37 0,24 0,17 
MOTIVAT  ERFOLG 0,4 0,42 0,48 0,54 
ERFOLG  ANLAGE 0,3 0,25 0,21 0,19 
ERFOLG  UMWELT 0,4 0,48 0,30 0,22 
ERFOLG  MOTIVAT 0,5 0,47 0,66 0,83 
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Vermutlich resultiert die Überlegenheit der latenten Methodologie aus ihrer Möglichkeit, die unterschied-
lichen Reliabilitäten der Indikatoren zu berücksichtigen. 
Bei diesen Vergleichen ist natürlich zu beachten, dass sie auf Ergebnissen einer einzigen Zufallsstichpro-
be basieren. 
 
In der Regel ist es übrigens wenig hilfreich, aus einer einzelnen manifesten Variablen durch Testhalbie-
rung ein Messmodell mit einer latenten Variablen zu erzeugen (vgl. Cohen et al. 2003, S. 474). 
 
Zum Abschluss noch ein Hinweis zur Gestaltung der Pfaddiagramme: Wenn sich die von Amos eingetra-
genen Parameterschätzer zu nahe kommen, können Sie mit dem -Werkzeug deren Positionen verän-
dern. 
 



 

AWS.AMOS.3 : 8. Juli 2005 51 
 

Analyse von Strukturgleichungsmodellen mit Amos 5.0 
 

6 Modifikationsindikatoren 
In den bisherigen Beispielen haben alle Modelle so gut gepasst, dass wir uns nicht für Hilfsmittel zur Di-
agnose von Spezifikationsfehlern interessieren mussten. Im aktuellen Abschnitt beschäftigen wir uns an-
hand eines neuen Beispiels damit, wie lokale Modellschwächen mit Hilfe der so genannten Modifikations-
indikatoren aufgespürt werden können. Diese Statistiken geben für einen fixierten oder restringierten Para-
meter an, welche Reduktion der χ2-Statistik zum Modellgültigkeitstest zu erwarten ist, wenn der Parameter 
freigesetzt und anschließend das (erweiterte) Modell neu geschätzt wird. Ein Modifikationsindikator enthält 
also die χ2-Differenz aus zwei geschachtelten Modellen, die sich um einen Parameter unterscheiden. Er kann 
daher bei Verwendung der ML-, GLS- oder ADF-Schätzmethode anhand der χ2-Verteilung mit einem Frei-
heitsgrad beurteilt werden. Je nach bevorzugter Regel wird man Werte größer 4 (≈ 95% - Fraktil) oder 7 (≈ 
99% - Fraktil) als Kritik der Empirie an der zugrunde liegenden Fixierung oder Restriktion interpretieren. 
Amos schätzt außerdem für jeden fixierten bzw. restringierten Parameter seine erwartete Veränderung bei 
Freisetzung (Bezeichnung im Ergebnisprotokoll: Par Change). 
 
In einer Studie von Steyer (1988, S. 312) wurden bei 179 Studierenden der Universität Trier im Abstand 
von zwei Monaten jeweils 2 Tests für die Zustandsangst erhoben. Zu jedem Zeitpunkt sind also zwei Indika-
toren für die latente Variable Zustandsangst vorhanden. Diese wird als zeitlich variabel angenommen, so dass 
für die beiden Zeitpunkte unterschiedliche, gleichwohl korrelierte, latente Variablen vorliegen. Insgesamt 
sind folgende Variablen zu modellieren: 
  I1T1  Erster Indikator, erhoben zum ersten Zeitpunkt 
  I2T1  Zweiter Indikator, erhoben zum ersten Zeitpunkt 
  I1T2  Erster Indikator, erhoben zum zweiten Zeitpunkt 
  I2T2  Zweiter Indikator, erhoben zum zweiten Zeitpunkt 
  LAST1 Latente Zustandsangst zum ersten Zeitpunkt 
  LAST2 Latente Zustandsangst zum zweiten Zeitpunkt 
  FI1T1, .., 
  FI2T2 Residuen der Indikatorvariablen 
Die Kovarianzmatrix der manifesten Variablen finden Sie in der SPSS-Matrix-Datendatei Steyer.sav 
(genaue Bezugsquelle: siehe Einleitung): 

 
Eine Besonderheit dieser Datei besteht darin, dass sie Stichproben-Kovarianzen enthält (ermittelt mit 
Stichprobengröße N als Nenner), also keine erwartungstreuen Schätzer der Populationsvarianzen (ermit-
telt mit dem Nenner N-1). Amos verwendet für Maximum Likelihood – Schätzungen per Voreinstellung 
genau solche Stichproben-Kovarianzen, interpretiert die Einträge in einer SPSS-Matrix-Datendatei aber 
als erwartungstreue Schätzer und konvertiert diese per Voreinstellung automatisch. In unserem Fall ist 
diese Automatik natürlich unerwünscht, weil die Kovarianzen in Steyer.sav nicht von SPSS aus Rohda-
ten (nach der Formel für erwartungstreue Schätzer) berechnet, sondern direkt eingegeben wurden. Daher 
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informieren wir Amos nach View/Set > Analysis Properties > Bias darüber, dass die von uns ange-
lieferten Covariances supplied as input (ohne Vorbehandlung) für eine Maximum Likelihood - 
Schätzung geeignet sind: 

 
 
Wir wollen das folgende Modell prüfen: 

LAST1

I2T1

err_var

FI2T1

1

1

I1T1

err_var

FI1T1

1

1

LAST2

I2T2

err_var

FI2T2

I1T2

err_var

FI1T2

1

1

1

1

 
Es enthält zahlreiche Restriktionen: 

• Es wurden einige potentielle Ladungspfade weggelassen 
• Die verbliebenen Ladungen wurden alle auf den Wert 1 fixiert, was insbesondere eine Gleichheits-

restriktion bedeutet. 
• Von einer weiteren Gleichheitsrestriktion sind die vier Fehlervarianzen betroffen. 

Bei einem derart strengen Modell sind Anpassungsschwächen zu erwarten, und wir wollen daher nach 
View/Set > Analysis Properties > Output die Ausgabe von Modifikationsindikatoren verlangen: 
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Amos protokolliert nur Modifikationsindikatoren oberhalb der im Feld Threshold for modification 
indices angegebenen kritischen Grenze. Wir entscheiden uns für „Tests“ auf dem 5%-Niveau (siehe 
oben). 
 
Wir erhalten das folgende Ausgabe-Pfaddiagramm mit unstandardisierten Schätzergebnissen: 

21,97
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I2T1

2,86

FI2T1

1,00

1

I1T1

2,86

FI1T1

1,00

1

25,18
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I1T2
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FI1T2

1,00

1

1,00
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Wider Erwarten akzeptiert der χ2-Modellgültigkeitstest die strengen Restriktionen, was die Eignung des 
Beispiels für den aktuellen Abschnitt etwas in Frage stellt: 

Result (Default model) 

Minimum was achieved  
Chi-square = 7,534 
Degrees of freedom = 6  
Probability level = ,274 
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Trotz der günstigen Gesamtbeurteilung artikulieren sich lokale Schwächen des Modells durch Modifika-
tionsindikatoren oberhalb der kritischen Grenze von 4: 

Modification Indices (Group number 1 - Default model) 

Covariances: (Group number 1 - Default model) 

M.I. Par Change
FI2T1 <--> FI2T2 4,527 ,849
 
Regression Weights: (Group number 1 - Default model) 

M.I. Par Change
I1T2 <--- I2T1 4,600 -,075
I2T2 <--- I2T1 4,925 ,077 

Zu Gunsten eines möglichst einfachen Modells wird man eventuell nach einem bestandenen Globaltest auf 
eine Fit-Optimierung verzichten. Hier soll jedoch demonstriert werden, wie man auf bedeutsame Modifika-
tionsindikatoren reagieren kann. 
Die Wahl der zuerst zu beseitigenden Restriktion sollte sich nicht strikt an der Modifikationsindikatoren-
Rangreihe orientieren, sondern auch theoretisch begründbar sein. Im Beispiel ist der Modifikationsindex für 
die Kovarianz von FI2T1 und FI2T2 (im Modell auf 0 fixiert) mit einem Wert von 4,53 „signifikant“ und 
stellt eine durchaus nachvollziehbare Kritik an unserem Modell dar: Die beiden Messungen des zweiten 
Indikators haben vermutlich über den Einfluss der latenten Variablen hinaus eine gemeinsame Wurzel. 
Durch Freisetzen der Kovarianz von FI2T1 und FI2T2 reduziert sich die χ2-Statistik zum Modellgültig-
keitstest um 4,59 (etwas stärker als vom Modifikationsindikator prognostiziert) von 7,53 auf 2,94: 

Minimum was achieved  
Chi-square = 2,939  
Degrees of freedom = 5  
Probability level = ,709 

Das erweiterte Modell sieht so aus: 

21,78
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,85  
In der Textausgabe zum erweiterten Modell finden sich keine signifikanten Modifikationsindikatoren 
mehr. 
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7 Explorative Techniken 
Obwohl die Strukturgleichungsanalyse tendenziell eine eher konfirmatorische (hypothesenprüfende) Me-
thodologie darstellt, erlaubt sie auch eine explorative (hypothesengenerierende bzw. modellsuchende) 
Datenanalyse. Amos kann seit der Version 5 einen durch optionale Parameter aufgespannten Raum von 
potentiellen Modellen nach einer „optimalen Lösung“ durchsuchen. Bei dieser Spezifikationssuche wer-
den alle potentiellen Modelle geschätzt und nach diversen Kriterien beurteilt. 

7.1 Gütemaße 
Bevor wir uns mit technischen Details dieser Spezifikationssuche befassen, sollen zunächst einige Güte-
maße angesprochen werden, welche die bisher ausschließlich betrachtete Prüfgröße des χ2-Gültigkeits-
tests (samt Überschreitungswahrscheinlichkeit) bei der Modellbeurteilung wesentlich ergänzen können. 
Bei den folgenden Ausführungen verwenden wir einige Bezeichnungen aus der Amos-Ausgabe: 

• CMIN 
Prüfgröße des χ2-Modellgültigkeitstests 

• NPAR 
Anzahl der frei schätzbaren Parameter 

• N 
Stichprobengröße 

• DF 
Anzahl der Freiheitsgrade ( = Anzahl der Stichprobenmomente – NPAR) 

 
CMIN und die zugehörige Überschreitungswahrscheinlichkeit P 

In die Prüfgröße CMIN des χ2-Modellgültigkeitstests gehen ein: 

• Die minimale Diskrepanz FMIN zwischen der Stichproben-Momentenmatrix und der Modellimp-
likation, wobei die Diskrepanzdefinition von der Schätzmethode abhängt 

• Die um 1 verminderte Stichprobengröße N 
Speziell die starke Abhängigkeit von der Stichprobengröße beeinträchtigt die Nützlichkeit von CMIN 
(und zugehöriger Überschreitungswahrscheinlichkeit P) zur Modellbeurteilung: 

CMIN := (N – 1) ⋅ FMIN 
Bei gleicher Stichproben-Momentenmatrix und gleichem Modell führt ein doppelt so großes N zu einer unge-
fähr doppelt so großen CMIN-Statistik. Bei Gültigkeit des Modells ist dies eine sinnvolle Normierung, weil 
bei wachsendem N eine immer besserer Fit von Modell und Daten zu erwarten ist. Ist das Modell jedoch 
streng genommen falsch, was in den Sozial- und Wirtschaftswissenschaften als sicher angenommen werden 
kann, so konvergiert die Stichproben-Momentenmatrix bei wachsendem N nicht gegen die vom Modell imp-
lizierte Matrix, und CMIN steigt drastisch an. Dies bedeutet, dass die Power des χ2-Tests zur Aufdeckung 
des als sicher anzunehmenden Modelldefekts mit N ansteigt. Damit geht auch für ein „gut passendes“ Modell 
die Wahrscheinlichkeit gegen 1, dass es (streng genommen zu Recht) als falsch erkannt wird. 
 
CMIN/DF 

Bei den Schätzmethoden mit approximativer 2
dfχ -Verteilung der CMIN-Statistik (ML, GLS, ADF) ist für 

gültige Modelle ein Quotient nahe 1 zu erwarten. Empfehlungen zur Obergrenze für akzeptable Modelle 
schwanken zwischen 2 und 5. 
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F0, RMSEA und PCLOSE 
Als F0 bezeichnet Amos die folgende Schätzung der minimalen Diskrepanz zwischen der Populations-
Momentenmatrix und der Modellimplikation: 

⎟
⎠
⎞

⎜
⎝
⎛

−
−

= 0,
1

max:
N

DFCMINF0  

Während das F0-Kriterium keine Belohnung für sparsame Modelle enthält, ist diese im RMSEA-Maß 
(Root Mean Square Error of Approximation) enthalten: 

DF
F0RMSEA =:  

Amos liefert unter der Bezeichnung LO90 bzw. HI90 auch eine untere bzw. obere Schranke für das 90% 
- Vertrauensintervall zum RMSEA-Wert. 
 
Browne & Cudeck (1993, S. 136ff) geben zum RMSEA-Maß folgende Bewertungshinweise: 

RMSEA ≤ 0,05 gut 
0,05 < RMSEA ≤ 0,08 akzeptabel 
RMSEA > 0,08 inakzeptabel 

 
Amos liefert unter der Bezeichnung PCLOSE eine Größe, die tendenziell als Überschreitungswahr-
scheinlichkeit zur folgenden Nullhypothese interpretiert werden kann: 

H0: RMSEA ≤ 0,05 
 
AIC, BCC und BIC 
Beim Akaike Information Criterion (AIC), beim Browne-Cudeck Criterion (BCC) und beim Bayes 
Information Criterion (BIC) handelt es sich um informationstheoretische Gütemaße, die komplexe Mo-
delle (mit zahlreichen Parametern) bestrafen. Wir beschränken uns auf die Darstellung des Akaike Infor-
mation Criterions, welches die historische Vorreiterrolle gespielt hat und eine angenehm einfache Formel 
besitzt: 

AIC := CMIN + 2 NPAR 
Hinsichtlich der wachsenden Tendenz zur Bevorzugung sparsamer Modelle bilden die drei Gütemaße 
folgende Rangreihe: 

AIC < BCC < BIC 
 
AIC0, BCC0 und BIC0 
Subtrahiert man vom jeweiligen Gütemaß das Minimum aller zum Vergleich anstehender Modelle, dann 
erreicht das beste Modell den Wert 0 und die Interpretation wird etwas erleichtert. 
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7.2 Spezifikationssuche 
Wir greifen auf die in Abschnitt 5 beschriebenen Simulationsdaten und das dort vorgestellte Pfaddia-
gramm zurück und starten mit dem -Werkzeug das Specification Search – Fenster, welches sich 
zunächst auf eine Symbolleiste beschränkt: 

 
Bei eingerastetem  - Schalter deklarieren wir im Pfaddiagramm per Mauklick 3 Parameter als optio-
nal: 

 
Bei eingerastetem  - Schalter kann man einen Parameter per Mausklick wieder in den Normalzustand 
zurück versetzen. 
Damit die optionalen Parameter nicht nur farblich, sondern auch über den Linientyp hervorgehoben wer-
den, muss man nach View/Set > Interface Properties > Accessibility das Kontrollkästchen Alter-
native to color markieren: 

 

ANE MOTIVAT

ERFOLG

FM

FE

ANE2 FANE2 1 

ANE1 FANE1 1 1 

1

ANLAGE
ANLAGE2 FANL2 

ANLAGE1 FANL1 

1 

1 1 

UMWELT
UMWELT2FUMW2 

UMWELT1FUMW1 

1 

1 1 

MOTIVAT1 FMOT11 1 

MOTIVAT2 FMOT2
1 

1

ERFOLG1 FERF1

ERFOLG2 FERF2

1 

1 

1
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Die optionalen Parameter legen fest, welche Modelle bei der Spezifikationssuche zu berücksichtigen sind, 
wobei jeder einzelne optionale Parameter einen Faktor mit den folgenden Zuständen beisteuert: 

• Parameter ist auf 0 fixiert 
• Parameter ist frei schätzbar 

Gemeinsam ergeben k optionale Parameter 2k Kombinationen bzw. Kandidaten-Modelle, so dass im Bei-
spiel 8 Modelle zur Konkurrenz zugelassen sind. 
 
Mit einem Mausklick auf den Schalter  der Spezifikations-Symbolleiste lässt man alle Modelle schät-
zen: 

 
Anschließend erscheinen im Fenster der Spezifikationssuche die Ergebnisse aller Modelle, z.B.: 

 
In den vergleichsrelevanten Spalten ist der Wert des günstigsten Modells unterstrichen. 
 
Bei Verwendung mehrerer Kriterien ist kaum damit zu rechnen, dass ein Modell alle Kriterien für sich 
entscheidet. Im Beispiel kommen zwei Modelle in die engere Wahl: 

• Modell 8 
Dies ist das wahre Modell der Simulationsstudie (siehe Abschnitt 5). Es entscheidet die CMIN – 
abhängigen Disziplinen für sich. 

• Modell 5 
Modell 5 gewinnt die informationstheoretischen Disziplinen. Hier ist im Vergleich zum Modell 5 
die Kovarianz der Residuen zu den endogenen Variablen auf 0 fixiert. Weil es sich dabei um ei-
nen eher technischen Parameter ohne große inhaltliche Bedeutung handelt, unterscheiden sich die 
beiden Spitzenmodelle nicht wesentlich. 
Per Doppelklick auf seine Zeile im Spezifikationsfenster erhält man zu einem Modell sein Pfad-
diagramm, z.B. bei Modell 5: 
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Über den Schalter  des Spezifikationsfensters ist eine Dialogbox zugänglich, die zahlreiche grafische 
Hilfen zur Modellauswahl bietet: 

 
Im Scatter-Plot sind die (CMIN, NPAR) – Paare aller Modelle zu sehen, wobei man per Mausklick auf 
einen Punkt die Nummer und den CMIN-Wert des zugehörigen Modells erhält. Eine verschiebbare Gera-
de kennzeichnet für ein Fit measure alle Modell mit konstantem Wert für dieses Kriterium. So zeigt 
sich in unserem Beispiel, dass die Modelle 5 und 8 praktisch denselben BCC-Wert besitzen. 
 
In folgendem Plot ist der beste CMIN/DF – Wert für ein Modell mit 29, 28, 27oder 26 Parametern zu 
sehen: 

ANE MOTIVAT

ERFOLG

FM

FE

ANE2 FANE2 1 
ANE1 FANE1 1 1 

1
ANLAGE

ANLAGE2 FANL2 

ANLAGE1 FANL1 
1 

1 1 

UMWELT
UMWELT2 FUMW2 

UMWELT1 FUMW1 
1 

1 1 

MOTIVAT1 FMOT1 1 1 

MOTIVAT2 FMOT2 1 
1

ERFOLG1 FERF1 

ERFOLG2 FERF2 

1 
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1



 

AWS.AMOS.3 : 8. Juli 2005 60 
 

Analyse von Strukturgleichungsmodellen mit Amos 5.0 
 

 
Offenbar empfiehlt es sich nicht, weniger als 27 Parameter zu verwenden. 
 
Der folgende Scree-Plot dokumentiert für das beste Modell mit 27 Parametern eine deutliche Überle-
genheit beim CMIN/DF – Kriterium gegenüber dem besten Modell mit 26 Parametern (Reduktion um 
3,643), während bei einer weiteren Steigerung der Parameterzahl nur noch geringfügige Verbesserungen 
erreicht werden (0,301 bzw. 0,011): 
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8 Die simultane Analyse mehrerer Gruppen 
Arbuckle (1999, S. 209) nennt zwei wesentliche Vorteile der simultanen Analyse mehrerer Gruppen im 
Vergleich zu Einzelanalysen pro Gruppe: 

• Es können Signifikanztests zu Gruppenunterschieden hinsichtlich diverser Verteilungseigenschaf-
ten durchgeführt werden (z.B. Vergleich von Kovarianzmatrizen, Ladungsmustern, Pfadkoeffizien-
ten, Erwartungswerten). 
Dies ermöglicht insbesondere die Überprüfung von Interaktionshypothesen, allerdings mit der Ein-
schränkung auf kategoriale Moderatoren. Man kann z.B. untersuchen, ob die Gruppenzugehörigkeit 
den Effekt einer latenten exogenen Variablen auf eine latente endogene Variable moderiert. 

• Sind die Gruppen hinsichtlich wesentlicher Verteilungseigenschaften äquivalent, erlaubt die simul-
tane Analyse präzisere Parameterschätzungen. 

Im Demonstrationsbeispiel greifen wir wieder auf die Daten aus Attig (1983) zurück (vgl. Abschnitt 2), 
betrachten aber neben den jungen Probanden eine zusätzliche Stichprobe mit alten Teilnehmern. Dabei 
interessieren wir uns nur für die einfache und die unterstützte Erinnerungsleistung vor dem Gedächtnis-
training (Variablen: recall1, cued1). 
 
Die Daten jeder Gruppe werden in einer eigenen Datei erwartet. In unserem Beispiel kommen die SPSS-
Dateien Attg_yng.sav und Attg_old.sav zum Einsatz, die sich im Examples-Unterverzeichnis zum A-
mos 5 – Programmordner befinden. 
 
Weiterhin gelten folgende Regeln: 

• Per Voreinstellung sind die Pfaddiagramme der einzelnen Gruppen identisch. Wenn es dabei bleibt, 
muss also nur ein Pfaddiagramm gezeichnet werden. 

• Für unbenannte Parameter schätzt Amos in jeder Gruppe einen eigenen Wert. 
Die beiden ersten Regeln kann man also so zusammenfassen: Per Voreinstellung besitzen die Grup-
pen eine identische Modellstruktur, aber individuelle Parameterwerte. 

• Parameter aus verschiedenen Gruppen können durch identische Benennung gleich gesetzt werden 
(vgl. Abschnitt 4.3). Derartige Restriktionen erlauben sehr flexible Hypothesenprüfungen. 

Öffnen Sie in einem neuen Amos-Projekt über File > Data Files > File Name die Datei der jüngeren 
Probanden: 
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Erstellen Sie das folgende Pfaddiagramm: 

RECALL1 CUED1

Beipspiel 10 aus Arbuckle & Wothke (1999)
Simultane Analyse mehrerer Gruppen

Daten aus Attig (1983)
Group number 1  

In der Diagrammbeschriftung (zu erstellen mit dem -Werkzeug
 

) sorgt der Makro-Eintrag \group 
dafür, dass die aktuell dargestellte Gruppe stets erkennbar ist: 

 
 
Nun wollen wir noch eine zweite Gruppe in die Analyse aufnehmen und außerdem für beide Gruppen 
eine informative Bezeichnung vereinbaren. Dazu starten wir den Gruppenmanager mit 

Model-Fit > Manage Groups 
Alternativ kann der Gruppenmanager auch per Doppelklick auf einen Eintrag im Gruppenauswahlbereich 
des Amos-Fensters gestartet werden. 
Zunächst ersetzen wir die automatisch vergebene Gruppenbezeichnung Group number 1 durch Junge 
Probenden: 

 
Dann legen wir mit New eine weitere Gruppe an und benennen diese gleich passend. 
Schließlich muss über File > Data Files noch die Eingabedatei zur zweiten Gruppe vereinbart werden: 
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Nach unseren bisherigen Modellspezifikationen hat Amos in jeder Gruppe zwei Varianzen und eine Ko-
varianz zu schätzen. Es sind keine Restriktion und damit auch keine Freiheitsgrade für einen Modelltest 
vorhanden, wie die Textausgabe bestätigt: 

Computation of degrees of freedom (Default model) 

Number of distinct sample moments: 6
Number of distinct parameters to be estimated: 6

Degrees of freedom (6 - 6): 0
 
Result (Default model) 

Minimum was achieved  
Chi-square = ,000  
Degrees of freedom = 0  
Probability level cannot be computed 

 
Scalar Estimates (Junge Probanden - Default model) 

Maximum Likelihood Estimates 

Covariances: (Junge Probanden - Default model) 

Estimate S.E. C.R. PLabel 
RECALL1 <--> CUED1 3,225 ,944 3,416 *** 
Variances: (Junge Probanden - Default model) 

Estimate S.E. C.R. PLabel 
RECALL1 5,788 1,311 4,416 *** 
CUED1 4,210 ,953 4,416 ***  

 
Scalar Estimates (Alte Probanden - Default model) 

Maximum Likelihood Estimates 

Covariances: (Alte Probanden - Default model) 

Estimate S.E. C.R. PLabel 
RECALL1 <--> CUED1 4,887 1,252 3,902 *** 
Variances: (Alte Probanden - Default model) 

Estimate S.E. C.R. PLabel 
RECALL1 5,569 1,261 4,416 *** 
CUED1 6,694 1,516 4,416 ***  
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Das Ausgabe-Pfaddiagramm zeigt jeweils die Schätzergebnisse der im Gruppenauswahlbereich des A-
mos-Fensters markierten Gruppe, z.B.: 

 
 
Nun soll die Hypothese identischer Varianz-Kovarianzmatrizen geprüft werden. Dazu geben wir korres-
pondierenden Parametern in beiden Gruppen identische Namen: 

var_rec1

RECALL1

var_cue1

CUED1

cov_rc1  
Auch bei offener Object Properties – Dialogbox sind Gruppenwechsel per Mausklick auf die Einträge 
im Gruppenauswahlbereich möglich. 
Der χ2-Modelltest hat keine Einwände gegen die Gleichheitsrestriktionen, also gegen die Nullhypothese 
homogener Varianz-Kovarianzmatrizen: 
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Notes for Model (Default model) 

Computation of degrees of freedom (Default model) 

Number of distinct sample moments: 6
Number of distinct parameters to be estimated: 3

Degrees of freedom (6 - 3): 3
 
Result (Default model) 

Minimum was achieved  
Chi-square = 4,588  
Degrees of freedom = 3  
Probability level = ,205 

Neben den Schätzern sind auch die Standardfehler in beiden Gruppen gleich und dabei kleiner als im un-
restringierten Modell: 

Scalar Estimates (Junge Probanden - Default model) 

Maximum Likelihood Estimates 

Covariances: (Junge Probanden - Default model) 

Estimate S.E. C.R. PLabel 
RECALL1 <--> CUED1 4,056 ,780 5,202 ***cov_rc1 
Variances: (Junge Probanden - Default model) 

Estimate S.E. C.R. PLabel 
RECALL1 5,678 ,909 6,245 ***var_rec1 
CUED1 5,452 ,873 6,245 ***var_cue1  

Der eingangs erwähnte Präzisionsgewinn bei der simultanen Analyse mehrerer Gruppen stellt sich also 
genau dann ein, wenn durch Gleichheitsrestriktionen gemeinsame Parameterschätzungen möglich wer-
den. 
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Arbuckle, J. L. & Wothke, W. (1999). Amos 4.0 User’s Guide. Chicago, IL: SmallWaters Corporation. 
Arbuckle, J. L. (2003). Amos 5.0. Update to the Amos User’s Guide. Chicago, IL: SmallWaters Corpora-

tion. 
 
Weitere zitierte Literatur: 
Attig, M. S. (1983). The processing of spatial information by adults. Presented at the annual meeting of 

The Gerontological Society, San Francisco. 
Backhaus, K., Erichson, B., Plinke, W. & Weiber, R. (2003). Multivariate Analysemethoden (10. Aufl.). 

Berlin: Springer. 
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SPSS bietet auf der folgenden Webseite einige Informationen zu Amos: 
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Der Originalhersteller SmallWaters, Inc. betreibt die folgende Webseite: 

http://www.smallwaters.com/amos 
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10 Anhang 
Mit diesem SPSS-Programm wurden die in Abschnitt 5.1 diskutierten Simulationsdaten erzeugt: 
new file. 
set seed  = 13. 
 
* N Fälle generieren. 
input program. 
+ loop #i = 1 to 384. 
-  compute a = 1. 
-  end case. 
+ end loop. 
+ end file. 
end input program. 
 
* Exogene latente Variablen erzeugen. 
compute r = normal(1). 
compute ane = 2 * r + normal(2). 
compute anlage = 1.5 * r + normal(2.4). 
compute umwelt = 2.5 * r + normal(1.32). 
 
* erfolg initialisieren. 
compute erfolg = 0.3 * anlage + 0.4 * umwelt + normal(3). 
 
* Zeitschleife für Episoden wechselseitiger Beeinflussung. 
loop #i = 1 to 1000. 
  compute motivat = 0.3 * ane + 0.4 * erfolg + normal(3). 
  compute erfolg = 0.3 * anlage + 0.4 * umwelt + 0.5 * motivat + normal(2). 
end loop. 
exe. 
 
* Manifeste Indikatoren mit einer Reliabilität von 0.8 bzw. 0.6 erzeugen. 
compute ane1s = ane + normal(1.414). 
compute ane2s = ane + normal(2.309). 
compute anlage1s = anlage +  normal(1.414). 
compute anlage2s = anlage +  normal(2.309). 
compute umwelt1s = umwelt +  normal(1.414). 
compute umwelt2s = umwelt +  normal(2.309). 
 
* Manifeste Indikatoren mit einer Reliabilität von 0.8 erzeugen. 
* Empirisch ermittelte Var(motivat): 12,74. 
compute motiva1s = motivat +  normal(1.80). 
compute motiva2s = motivat +  normal(1.80). 
* Manifeste Indikatoren mit einer Reliabilität von 0.79 erzeugen. 
* Empirisch ermittelte Var(erfolg): 12,20. 
compute erfolg1s = erfolg +  normal(1.80). 
compute erfolg2s = erfolg +  normal(1.80). 
 
* Manifeste Variablen in den typischen Wertebereich schieben und vergröbern. 
do repeat arg = ane1s ane2s anlage1s anlage2s umwelt1s umwelt2s motiva1s motiva2s erfolg1s erfolg2s 
 /erg = ane1 ane2 anlage1 anlage2 umwelt1 umwelt2 motivat1 motivat2 erfolg1 erfolg2. 
+ compute erg = rnd(arg+13). 
end repeat. 
 
* Summe der Indikatoren bilden für einen fairen Latent-Manifest-Vergleich. 
compute ane12 = ane1 + ane2. 
compute anlage12 = anlage1 + anlage2. 
compute umwelt12 = umwelt1 + umwelt2. 
compute motiva12 = motivat1 + motivat2. 
compute erfolg12 = erfolg1 + erfolg2. 
 
format ane1 ane2 anlage1 anlage2 umwelt1 umwelt2 motivat1 motivat2 erfolg1 erfolg2 
 ane12 to erfolg12 (f2.0). 
 
save outfile = 'mc.sav' 
 /drop = a r ane anlage umwelt motivat erfolg. 
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