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1 Einleitung 
Von den Programmen der SPSS Data Entry – Familie werden verschiedenen Techniken zur Erfassung 
von Daten für die Weiterverarbeitung mit den SPSS-Statistikprogrammen unterstützt, wobei durchgängig 
SPSS-Datendateien (Namenserweiterung .sav) zum Austausch dienen. 
 
Die zentralen Funktionen des in diesem Manuskript behandelten Data Entry Builders sind: 

• Fragebogendesign 
Sie können ein Formular zur Verwendung bei der Datenerhebung (z.B. durch schriftliche Befragung) 
und bei der EDV-Erfassung entwerfen, oder für beide Anwendungsfälle angepasste Formulare ver-
wenden. 

• Datenerfassung 
Die Erfassung wird u.a. durch „Sprung-und-Füll - Regeln“ (Filterfragen) erleichtert und durch Plausi-
bilitätsprüfungen abgesichert. 

 
Außerdem bietet der Data Entry Builder u.a. folgende Möglichkeiten: 

• Einen Fragebogen zu einer existierenden SPSS-Datendatei erstellen 
• Beispielfragen aus einer Bibliothek übernehmen 
• Existierende SPSS-Datendateien auf Fehler prüfen 
• Vergleich von Dateien bei doppelter Erfassung aus Präzisionsgründen 
 
Neben dem Data Entry Builder vertreibt SPSS für den Einsatz auf Arbeitsplatzrechnern noch die auf Da-
tenerfassung und –prüfung beschränkte Variante Data Entry Station. Auf den vom Universitäts-Rechen-
zentrum Trier (URT) betreuten Pool-PCs stehen beide Programme zur Verfügung. 
 
Nicht verfügbar ist auf den URT-Anlagen hingegen der Data Entry Enterprise Server, der servergestützte 
Datenerfassungstechnologien unterstützt: 

• Data Entry Network Server 
Mit Hilfe dieses Servers können mehrere Erfasser simultan am selben Projekt arbeiten, so dass stets 
eine einheitliche und komplette Datenbasis vorhanden ist. 

• Data Entry Web Server 
Mit Hilfe dieses Servers können HTML-Varianten der per Data Entry Builder erstellten Formulare im 
Internet zur Online-Datenerfassung verwendet werden. 

 
Ein Einsatz von Data Entry Builder (ggf. ergänzt durch Data Entry Station) kommt in Frage, wenn bei 
einem größeren Projekt keine automatische Datenerfassung (z.B. Online-Datenerfassung oder Einscannen 
von schriftlichen Untersuchungsdokumenten) möglich ist. Im Unterschied zur tabellenorientierten Ein-
gabe mit dem SPSS-Basisprogramm bietet Data Entry eine Erfassungsmaske, die einen einzelnen Fall in 
übersichtlicher Form auf dem Bildschirm präsentiert. Zudem sorgen Plausibilitätskontrollen für eine re-
duzierte Fehlerquote und Filterfragen für eine rationelle Eingabe. Bevor diese Vorteile zum Tragen kom-
men, ist allerdings ein gewisser Lernaufwand zu investieren. 
 
Das vorliegende Manuskript beschränkt sich auf einen ersten Einstieg in die Möglichkeiten des Data En-
try Builders und orientiert sich dabei stark am SPSS-Handbuch: 

SPSS, Inc. (2003). SPSS Data Entry BuilderTM 4.0 User’s Guide. Chicago, IL. 
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2 Formulardesign 
Nach dem Start bietet Data Entry ein leeres Formularfenster, das Eigenschaftsfenster und das Builder-
Fenster, in dem später Objekte wie Formulare, Fragen, Variablen und Regeln verwaltet werden: 

 
Eventuell bevorzugen Sie es, die ToolBox-Symbolleiste mit den Steuerelementen für das Formularde-
sign aus ihrer Verankerung zu lösen und frei auf dem Arbeitsplatz zu positionieren: 

 
Sollte das Eigenschaftsfenster fehlen (Titelzeilenbeschriftung: Properties), lässt es sich mit dem Menü-
befehl 

View > Properties 
oder mit dem Schalter  aktivieren. 
 
Insgesamt bietet Data Entry eine objektorientierte Arbeitsumgebung, wie sie manchem Leser z.B. vom 
Dialogboxdesigner eines Programmentwicklungssystems her bekannt sein mag. Aus dieser Bemerkung 
darf aber nicht gefolgert werden, dass zur Verwendung von Data Entry Programmierkenntnisse erforder-
lich seien. 
Da sich alle Modifikationen mehrstufig rückgängig machen lassen (z.B. mit der Tastenkombination 
<Strg><Z>), kann man mit den mächtigen Werkzeugen von Data Entry risikofrei experimentieren und 
gestalten. 
 
Wir werden in Abschnitt 2 als Beispiel ein Formular zur Befragung von Übersee-Touristen erstellen und 
dabei die wichtigsten Erfassungswerkzeuge bzw. Fragetypen kennen lernen. 
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2.1 Optionsfeld-Fragen 
Zunächst erkundigen wir uns nach der Häufigkeit von Übersee-Reisen und entwerfen dazu eine Options-
feld-Frage mit vier Antwortmöglichkeiten: 

• Halten Sie die linke Maustaste über dem Optionsfeld-Symbol  in der ToolBox-Leiste ge-
drückt. 

• Wählen Sie aus der aufspringenden Matrix einen (4 × 1)-Spaltenvektor, und lassen sie die Maus-
taste los: 

 
• Klicken Sie mit dem nun optisch veränderten Mauszeiger im Formularfenster auf die linke obere 

Ecke der geplanten Eingabefläche. 
Sie sollten nun ungefähr den folgenden Data Entry - Arbeitsplatz vor Augen haben (Formularfenster, Ei-
genschaftsfenster, Werkzeug-Symbolleiste): 

 
Sie können das Rechteck mit der neuen Frage (vorläufiger Name: Question1) wie in einem Grafikpro-
gramm manipulieren: 

• Über die 8 Anfasser lässt sich die Größe ändern. 
• Zum Verschieben klickt man auf eine Position, die von keinem inneren Objekt belegt ist, und be-

wegt den Mauszeiger bei festgehaltener linker Maustaste. 
Im Container der neuen Frage befinden sich etliche Objekte (Fragen- bzw. Variablenlabel, Optionsschal-
ter mit Beschriftung ), deren Rechtecke sich analog in Größe und Position ändern lassen, wobei Data 
Entry nötigenfalls den Fragen-Container vergrößert. 
Die Texte der Frage und der Antwortalternativen können nach einem Doppelklick auf das jeweilige Ob-
jekt angepasst werden, wobei einige Felder eventuell verbreitert werden müssen. Übernehmen Sie bitte 
die Texte aus dem folgenden Formularfenster: 
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Ändern Sie die Schriftart der Frage über einen Mausklick auf den Erweiterungsschalter  in der Font-
Eigenschaft dieses Objektes (siehe Eigenschaftsfenster). Daraufhin erscheint der vertraute Windows-
Schriftartendialog: 

  
Das Ergebnis der Verschönerungsaktion: 
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Weil die Frage noch in einer Sprung-und-Füll – Regel angesprochen werden soll, lohnt es sich, per Ei-
genschaftsfenster einen aussagkräftigen Namen zu vereinbaren: 

 
Analog werden wir ohne besondere Ansage auch mit den weiteren Fragen verfahren. 
 

2.2 Fragen und Variablen 
Zu der neuen Frage hat Data Entry automatisch eine zugehörige Variable erstellt. Wählen Sie nach ei-
nem Rechtsklick auf den Fragen-Container aus dem Kontextmenü den Eintrag Variable Properties, um 
die gleichnamige Dialogbox zur Bestimmung der Variablenattribute zu erhalten. Auf dem Registerblatt 
General können Sie u.a.: 

• den vorgegebenen SPSS-Variablennamen abändern, 
Variablennamen sind bis zur SPSS-Version 11.5 (und bis zur Data Entry – Version 3.0) auf 8 Zeichen 
beschränkt. Jüngere Versionen akzeptieren auch längerer Variablennamen. 

• den Fragentext nötigenfalls erneut editieren, 
• das per Voreinstellung mit dem Fragentext verknüpfte Variablenlabel getrennt festlegen, 
• den Initialisierungswert festlegen, wobei es in unserem Fall zur Voreinstellung System missing 

kaum eine sinnvolle Alternative gibt, 
• entscheiden, ob die Frage bei einer Doppeleingabe zur Qualitätssteigerung einbezogen werden soll. 

 
 
Wie ein Blick auf das Registerblatt Format zeigt, legt Data Entry eine numerische Variable mit der (ü-
berdimensionierten) Breite von 8 Stellen an: 
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Auf dem Registerblatt Values können Sie 

• die numerische Kodierungen zu den Antwortalternativen individuell festlegen (Spalte Value), 
• die Formulierung der Antwortalternativen nötigenfalls erneut editieren (Spalte Response Item), 
• die per Voreinstellung mit den Antwortformulierungen verknüpften Wertelabel anders festlegen 

(Spalte Value Label). 
Im Beispiel sind keine Änderungen erforderlich: 

 
Schließen Sie die Dialogbox Variable Properties per Close. 
 

2.3 Fragen mit Texteingabe 
Wir erweitern das Formular nun um ein Texteingabefeld, mit dem das letzte Reiseziel in Übersee erfasst 
werden soll: 
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• Klicken Sie auf das Texteingabefeld-Symbol  in der ToolBox-Leiste. Die anschließende kurz an-
gezeigte Matrix können Sie ignorieren. 

• Klicken Sie mit dem optisch veränderten Mauszeiger im Formularfenster auf die linke obere Ecke der 
gewünschten Erfassungszone und ziehen Sie bei gedrückter linker Maustaste ein Rechteck auf. 

• Setzen Sie einen Doppelklick auf den Fragentext, um ihn abändern zu können: 

 
Im Beispiel wurden für die Eingabezone per Eigenschaftsfenster zwei Attribute geändert: 

• BorderStype = 1 - Box 
• SpecialEffect = 2 - Sunken 
 
Um mehr Platz für die Eingabe zu schaffen wurde zunächst der Container zur Frage und dann die Einga-
bezone selbst vergrößert. 
 
Beide lassen sich auch (wie jedes andere Objekt des Formulars) auf ihrer jeweiligen Basisfläche ver-
schieben, wobei durch geschickte Wahl der Anpackstelle die gewünschte Hierarchieebene signalisiert 
wird: 
Z.B. hier anfassen, um das gesamte Texterfas-
sungselement zu verschieben: 

 

Z.B. hier anfassen, um die Eingabezone innerhalb 
des Texterfassungselement zu verschieben: 

 
 
Gehen Sie folgendermaßen vor, um die vertikale Position der Beschriftung an diejenige der Eingabezone 
anzupassen (bei Orientierung an den Objektmitten): 

• Eingabezone markieren 
• <Umschalt>-Taste gedrückt halten 
• Beschriftung zusätzlich markieren 
• Schalter  oder den folgenden Menübefehl wählen: 

Layout > Align > Middles 
 
Über die Layout-Symbolleiste lassen sich auf analoge Weise 
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diverse Ausrichtungsarbeiten ausführen. 
 
Im Dialogfenster mit den Eigenschaften der zugehörigen Variablen (zu öffnen über den Eintrag Variable 
Properties im Kontextmenü zum Texteingabefeld) vereinbaren wir auf dem Registerblatt General den 
Namen ZIEL und auf dem Registerblatt Format den Variablentyp String mit einer Länge von 50 Zei-
chen: 

 
 

2.4 Gültigkeitsregeln 
Um den Einsatz einer Gültigkeitsregel üben zu können, erfassen wir per Texteingabefeld das Alter zum 
Zeitpunkt der ersten Übersee-Reise und erlauben dabei Werte von 15 bis 100 Jahre: 

 
Auf dem Registerblatt Format der Dialogbox Variable Properties (zu öffnen per Kontextmenü zur 
Frage) vereinbaren wir für die Variable zur neuen Textfeldfrage den Typ Numeric: 
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Auf dem Registerblatt Valid Values wird der zulässige Wertebereich festgelegt: 

 
Außerdem werden benutzerdefinierte MD-Indikatoren zugelassen (siehe Abschnitt 2.5). 
 
Auf eine fehlerhafte Eingabe macht Data Entry folgendermaßen aufmerksam: 

• akustisches Signal 
• Anzeige Invalid Value in der Statuszeile 
• Symbol  in der Leiste Case Navigation 
 
Per Regel-Assistent (vgl. Abschnitt 5) lassen sich auch Plausibilitätskontrollen realisieren, die Werte 
mehrerer Variablen berücksichtigen (so genannte checking rules). 
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2.5 Indikatoren für fehlende Werte 
Für das Alter zum Zeitpunkt der ersten Übersee-Reise soll der Ersatzwert 888 eingetragen werden, wenn 
eine solche Reise noch nicht stattgefunden hat. Auf dem Registerblatt Missing Values der Dialogbox 
Variable Properties (zu öffnen per Kontextmenü zur Frage) kann der Ersatzwert vereinbart werden, 
z.B.: 

 
 

2.6 Mehrfachwahlfragen 
Bei einem Mehrfachwahl-Set werden mehrere, sachlogisch unabhängige Informationen ermittelt. Genau 
genommen sind dabei mehrere Fragen (vom Ja-Nein - Typ) im Spiel, wobei man aber aus sprachlichen 
bzw. erhebungstechnischen Gründen nur eine Frage formuliert. Dieser einleitenden Frage folgen mehrere 
Angebote, von denen jedes einzelnen im Sinne einer Ja-Nein - Auskunft zu bearbeiten ist. 
Mysteriös wird die Angelegenheit in manchen Köpfen bei dem sinnlosen Versuch, die eine Frage in eine 
einzige Variable umzusetzen. Dabei ist alles ganz einfach. Wir haben es eigentlich mit mehreren Fragen 
und zugehörigen Antworten zu tun, die dementsprechend durch mehrere Variablen repräsentiert werden 
müssen. 
Im nun endlich fälligen Beispiel wird die Reiselust der Befragten im Hinblick auf sechs Kontinente ermit-
telt. Da die Neigung, Afrika zu bereisen, sachlogisch unabhängig von der Sehsucht nach Australien ist, 
werden sechs unabhängige Einzelinformationen festgestellt, also eigentlich sechs Fragen gestellt. Weil 
die sechsmalige Wiederholung eines relativ ähnlichen Fragetextes eine stilistische Katastrophe wäre, be-
dient man sich eines kompakteren Frageformates, z.B.: 
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Data Entry bezeichnet generell jedes Erfassungselement (z.B. vom Typ Optionsfeld oder Mehrfachwahl) 
als Frage (engl.: question). Manche Fragen in diesem technischen Sinn dienen jedoch zur Erfassung meh-
rerer Merkmale bzw. Variablen. 
 
Sie erhalten das obige Mehrfachwahl-Set im Data Entry – Formularfenster folgendermaßen: 

• Halten Sie die linke Maustaste über dem Kontrollkästchen-Symbol  in der Werkzeugpalette ge-
drückt. 

• Wählen Sie aus der aufspringenden Matrix einen (4 × 1)-Spaltenvektor 

 
und lassen Sie die Maustaste los. Klicken Sie mit dem nun optisch veränderten Mauszeiger im Formu-
larfenster auf die linke obere Ecke der gewünschten Position. 

Im Zwischenergebnis 

 
machen die Beschriftungen klar, dass die zum Set $set0001 zusammen gefassten Variablen Var00001 
bis Var00004 beteiligt sind. 
Nach einem Doppelklick können die Beschriftungen beliebig geändert werden. 
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Der kursiv gesetzte und eingerahmte Kommentar („Sie dürfen …“) in der obigen Variante ist ein eigen-
ständiges Objekt, das mit dem Textwerkzeug  erstellt und anschließend über das Eigenschaftsfenster 
modifiziert wurde: 

• AutoWrap = True 
• BorderStype = 1 - Box 
• Font = Arial, kursiv 

Die Dialogbox zur Auswahl der Schriftart erhalten Sie nach einem Klick auf den Schalter  in der 
Font-Zeile des Eigenschaftsfensters zum Textobjekt. 

 
Öffnen Sie nun bitte über den Eintrag Variable Properties im Kontextmenü zum Mehrfachwahl-Set 
das Dialogfenster zu den damit verknüpften Variablen. Es handelt sich um 4 eigenständige Variablen, die 
allerdings ein Set bilden, dessen Namen Data Entry auf der Registerkarte General protokolliert: 

 
Es tauchen gleich zwei Set-Bezeichnungen auf: 

• Der Name beginnt mit einem von Data Entry bereits eingetragenen Dollarzeichen. 
• Ein Alias findet in der Programmiersprache JScript Verwendung, die in Data Entry zur Formulierung 

von Regeln verwendet wird (s.u.). Er ist z.B. erforderlich, wenn der Name einer SPSS-Variablen bzw. 
eines Variablen-Sets mit einem $-Zeichen beginnt, was bei Sets unvermeidlich ist. 

Bei Counted value for dichotomies ist zu erfahren, dass die Variablen im Set bei der Datenerfassung 
eine 1 erhalten, wenn ein Kontrollkästchen markiert ist. 
 
Auf der Registerkarte Members kann man besichtigen (oder auch beeinflussen), welche Variablen zum 
Set der Mehrfachwahlfrage gehören sollen: 
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Vermutlich möchten Sie die von Data Entry vorgegebenen, wenig aussagekräftigen Variablennamen än-
dern. Das geht u.a. in der Variable Properties – Dialogbox zu einem einzelnen Kontrollkästchen, z.B.: 
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2.7 Optionsfeld-Matrizen 
Für Serien von Likert-Skalen mit identischem Antwortformat bietet Data Entry Optionsfeld-Matrizen, 
z.B.: 

 
 
Diese Matrix zur Erfassung von 3 Beurteilungen können Sie folgendermaßen erstellen: 

• Halten Sie die linke Maustaste über dem Optionsfeld-Matrizen-Symbol  in der ToolBox-Leiste 
gedrückt. 

• Wählen Sie in dem aufspringenden Fenster eine (3 × 5)-Matrix: 

 
• Klicken Sie mit dem nun optisch veränderten Mauszeiger im Formularfenster auf die linke obere Ecke 

der geplanten Eingabefläche. Es erscheint der folgende Rohling mit Zeilen- und Spaltenbeschriftun-
gen, die nur beim Formulardesign sichtbar sind: 

 
• Ändern Sie nach einem Doppelklick die Texte. Einem markierten Textobjekt ordnet man über die 

Font-Eigenschaft eine Schriftart zu. Das Zentrieren gelingt über die Eigenschaft HorizontalAlign-
ment. 

• Markieren Sie alle Optionsschalter, um ihre Gestalt per ButtonStyle-Eigenschaft zu ändern. 
• Um die Breite der 5 Optionsschalter-Spalten einheitlich neu festzulegen, markiert man sie per Maus-

klick auf die Beschriftung einer betroffenen Spalte und wählt dann einen geeigneten Wert für die Ei-
genschaft Width (z.B. 80). 

• Für die einleitende Fragenbeschriftung sorgt im Beispiel ein separates Textobjekt (mit dem –
Werkzeug erstellt). 
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Um vor einer (per Mausklick auf ihre Beschriftung) markierten Matrixzeile eine zusätzliche Zeile einzu-
fügen, wählt man den Menübefehl 

Edit > Matrix > Insert > Row 
Das Löschen einer Zeile gelingt am schnellsten durch Löschen der zugehörigen Variablen im Builder-
Fenster (siehe Abschnitt 3). 
 
Um anstelle von quadratischen oder runden Kästchen in jeder Zeile beschriftete Antwortalternativen an-
zubieten, wählt man für die Eigenschaft ButtonStyle der betroffenen Optionsschalter den Wert Capti-
on text. Bis zu diesem Ergebnis 

 
sind noch folgende Schritte erforderlich: 

• Man setzt die Spaltenbeschriftungen vorübergehend auf die gewünschten Texte für die Antwortalter-
nativen, wobei die Texte in allen Zeilen übernommen werden. 

• Sollen die Spaltenbeschriftungen von den Antwortalternativen abweichen, geht man so vor: 
o Man markiert die Optionsfeld-Matrix per Mausklick auf den unteren Rand ihres Containers, 

um ihre Eigenschaft ResponeTextUpdates auf den Wert False zu setzen. 
o Man legt die Spaltenbeschriftungen neu fest, wobei sich die Beschriftungen der Antwortalter-

nativen nicht ändern. 
 
Von den weiteren Möglichkeiten zur Gestaltung einer Optionsfeld-Matrix sollen noch erwähnt werden: 

• Spalten einfügen bzw. löschen 
• Zeilen bzw. Spalten verschieben 
 

2.8 Listen 
Eignet sich eine Variable zur Erfassung per Optionsfeld, kann in einer Erfassungsmaske (jedoch nicht im 
gedruckten Fragebogen) alternativ auch eine Liste verwendet werden. Data Entry unterstützt zwei Varian-
ten: 
 

2.8.1 Versteckte Liste 
Eine versteckte Liste belegt auf dem Bildschirm wenig Platz, weil die Antwortalternativen erst nach ei-
nem Mausklick ausgeklappt werden („Drop-Down-Liste“), z.B.: 
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Eine versteckte Liste wird folgendermaßen eingerichtet: 

• Klicken Sie in der ToolBox-Leiste auf das Symbol  für die versteckte Liste. Die anschließende 
kurz angezeigte Matrix können Sie ignorieren. 

• Klicken Sie mit dem nun optisch veränderten Mauszeiger im Formularfenster auf die linke obere 
Ecke der geplanten Eingabefläche. Alternativ können Sie mit festgehaltener Maustaste gleich den 
Container für die versteckte Liste zur gewünschten Größe aufziehen. 

• Markieren Sie die Liste, und setzen Sie einen Doppelklick auf die Zelle ihrer ListItems-
Eigenschaft, so dass in folgender Dialogbox die Antwortalternativen vereinbart werden können: 

 
Wie ein Blick auf die zugehörigen Variable Properties zeigt, legt Data Entry eine numerische 
Variable an und kodiert die Antwortalternativen durch die Werte 1, 2, 3, usw.: 
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Auf dem Registerblatt General der Dialogbox Variable Properties kann man die Voreinstel-
lung (Default Value) SYSMIS bei Bedarf ersetzen: 

 
 
Ein Kombinationsfeld, das sowohl eine Auswahlliste als auch eine freie Texteingabemöglichkeit bietet, 
ist in Data Entry nicht vorhanden. Jedoch lässt sich mit dem Sonstiges-Werkzeug (siehe unten) eine 
vergleichbare Funktionalität erzielen. 
 

2.8.2 Einfachwahlliste 
Bei einer Einfachwahlliste werden stets alle Antwortalternativen angezeigt, von denen der Erfasser genau 
eine wählen kann, z.B.: 

 
Eine Einfachwahlliste wird folgendermaßen eingerichtet: 

• Klicken Sie auf das Einfachwahllisten-Symbol  in der ToolBox-Leiste. Die anschließende 
kurz angezeigte Matrix können Sie ignorieren. 

• Klicken Sie mit dem nun optisch veränderten Mauszeiger im Formularfenster auf die linke obere 
Ecke der geplanten Eingabefläche. 

• Markieren Sie die Liste, und setzen Sie einen Doppelklick auf die Zelle ihrer ListItems-
Eigenschaft, so dass in der Dialogbox List Items die Antwortalternativen vereinbart werden kön-
nen (siehe Abschnitt 2.8.1). 
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2.9 Antwortalternative Sonstiges 
Bei Optionsfeldern, Listen und Mehrfachwahlfrage kann man eine offene Antwortalternative erlauben, 
z.B.: 

 
In diesem Fall legt Data Entry eine zusätzliche Variable vom Datentyp String an (Länge: 255 Zeichen). 
 
Beim Hinzufügen der Sonstiges-Alternative können Sie so vorgehen: 

• Klicken Sie auf das Other-Symbol  in der ToolBox-Leiste. 
• Klicken Sie mit dem nun optisch veränderten Mauszeiger im Formularfenster auf eine Frage mit 

zulässigem Typ (Optionsfeld, Liste, Mehrfachwahlfrage). 
Es entsteht eine Gruppe mit der bisherigen Frage und der hinzugefügten offenen Frage, und die Contai-
ner-Verschachtelung steigt dementsprechend. 
 

2.10 Tabulatorreihenfolge und Nummerierung 
Nach dem Einfügen oder Verschieben von Fragen kann es sinnvoll werden, über 

Layout > Tab Order and Numbering 
die Tabulatorreihenfolge für die Datenerfassung neu festzulegen, wozu in folgender Dialogbox markierte 
Fragen bzw. Antwortalternativen mit den Pfeilschaltern zu verschieben sind: 

 
 
Man kann eine Frage bzw. Fragengruppe automatisch nummerieren lassen, indem man ihre Eigenschaft 
Number auf den Wert True setzt. Geschieht dies im Beispiel mit allen Fragen, resultiert folgendes Er-
gebnis: 
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Die Nummer 5 gehört im Beispiel zur explizit über 

Layout > Group Items 
angelegten Gruppe aus der separat per –Werkzeug eingefügten Überschrift und der Optionsfeld-
Matrix. 
 
Setzt man die Eigenschaft AutoNumber des Formular-Objekts auf True, werden neue Fragen automa-
tisch nummeriert. 
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3 Das Builder-Fenster 
Das Builder-Fenster zeigt die zu einem Projekt gehörenden Objekte im Überblick: 

• Nach View > Forms bzw.  die Liste der Formulare 

• Nach View > Questions bzw.  die Liste der Fragen 

• Nach View > Variables bzw.  die Liste der Variablen und Sets 

• Nach View > Rules bzw.  die Liste der Regeln 
In unserem Beispiel-Projekt haben wir eine Gültigkeitsregel für die Variable ALTER kennen gelernt 
(vgl. Abschnitt 2.4). Später wird eine Sprung-und-Füll-Regel vorgestellt (siehe Abschnitt 5). Daneben 
unterstützt Data Entry noch Quervergleichs-Regeln (so genannte checking rules), die Plausibilitäts-
kontrollen unter Verwendung von Daten aus mehreren Variablen vornehmen. 

• Nach View > Procedures bzw.  die Liste der Prozeduren 
Die in der Programmiersprache JScript formulierten Regeln können Unterprogramme verwenden, die 
man in einer Programmierumgebung erstellt (siehe Abschnitt 6.4). 

 
Beim Löschen von Fragen verschwinden die zugehörigen Variablen nicht, so dass man das Builder-
Fenster benötigt, um obsolet gewordene Variablen zu entfernen. 
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4 Datenerfassung 
Wir können das definierte Formular nun dazu verwenden, Daten zu erfassen, die z.B. durch Telefoninter-
views oder durch eine schriftliche Befragung unter Verwendung unseres ausgedruckten Fragebogens 
(File > Print im Formularfenster) entstehen können. 
 

4.1 Formulareingabe 
Die erfassungsbereite Version unseres Formulars erhalten Sie vom Designer- oder Builder-Fenster aus 
über den Schalter  oder den Menübefehl: 

View > Form Entry 
Gehen sie folgendermaßen vor, um die Daten eines Falles einzugeben: 

• Verwenden Sie die vertikalen Pfeiltasten oder die Maus, um eine Antwortkategorie zur ersten Frage 
auszuwählen. 

• Springen Sie mit der Tabulatortaste  zur zweiten Variablen. 
• Tragen Sie dort ein Reiseziel ein, und springen Sie mit der Tabulatortaste 

 
 zur dritten Frage, 

also zur Mehrfachwahlfrage. 
• Zwischen den einzelnen Teilfragen bzw. Variablen des Sets können Sie sich mit der Tabulatortaste 

bewegen, wobei die Rückwärtsbewegung durch zusätzliches Drücken der Umschalttaste erreicht 
wird. Die gewünschten Ausprägung für ein Kontrollkästchen (für eine Variable) wählt man per Leer-
taste oder Mausklick, wobei drei Zustände möglich sind: 
o ein leeres Kästchen steht für den Wert 0 (im Beispiel: Afrika, Australien) 
o ein Häkchen auf weißem Grund steht für den Wert 1 (im Beispiel: Amerika) 
o ein Häkchen auf grauem Grund steht für einen fehlenden Wert (SYSMIS, im Beispiel: Asien) 

 
 
Mit den Daten eines fiktiven Falles sieht das Formular-Erfassungsfenster, dessen Größe sich übrigens 
nicht ändern lässt, so aus: 
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Wenn Sie die letzte Frage verlassen, wird ein neuer Fall begonnen, wobei SPSS die automatisch generier-
te Fallnummer oberhalb des Formulars anzeigt. 
 
Mit der Navigationsleiste kann man sich innerhalb der bearbeiteten SPSS-Datendatei bewegen: 

 
 
Mit File > Save speichert man die bisher erfassten Fälle in die bearbeitete Datendatei. 
 
Mit dem Schalter  kehrt man zum Formulardesigner zurück. 
 

4.2 Tabelleneingabe 
Neben der formular-orientierten Eingabe ist auch eine tabellen-orientierte Eingabe möglich, die an die 
Arbeit mit dem Dateneditor des SPSS-Basissystems erinnert. Sie wird vom Designer- oder Builder-
Fenster aus über den Schalter  oder den Menübefehl: 

View > Table Entry 
aufgerufen. Nachdem wir bereits einen Fall erfasst haben, wird uns folgendes Fenster präsentiert: 
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Bei Variablen mit einer festen Liste möglicher Ausprägungen kann die Eingabe auch per Drop-Down-
Menü erfolgen. 
 
Mit dem Schalter  kehrt man zum Formulardesigner zurück. 
 

4.3 Datenanalyse mit SPSS 
Weil Data Entry ein zu SPSS kompatibles Dateiformat verwendet, können wir unsere Datei nach der Da-
tenerfassung sofort mit SPSS verarbeiten. Vier Beispiel-Fälle ergeben im Dateneditor-Fenster folgendes 
Bild (Wertelabels eingeschaltet mit Ansicht > Wertelabels): 
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5 Sprung-und-Füll - Regeln 
Bei Personen, die noch keine Überseereise absolviert haben, ist unsere Frage nach dem letzten Reiseziel 
in Übersee unpassend. Data Entry bietet die Möglichkeit, in Abhängigkeit von bereits bekannten Vari-
ablenausprägungen unzutreffende Fragen bzw. Variablen zu überspringen und mit geeigneten Ersatzwer-
ten zu versorgen. Wir werden nun mit Hilfe eines Assistenten die folgende Sprung-und-Füll - Regel ver-
einbaren: 

Wenn Variable WIEOFT = 1, dann: 
• Versorge die alphanumerische (!) Variable ZIEL automatisch mit dem Wert nicht anwendbar. 
• Versorge die numerische Variable ALTER mit dem Ersatzwert 888 (benutzerdefinierter Mis-

sing Values – Indikator, siehe Abschnitt 2.5) 
• Springe zur Frage nach den Reiseabsichten 

Starten Sie bitte den Regelassistenten mit 
Rules > Rule Wizard 

Im der ersten Dialogbox entscheiden wir uns für eine Sprung-und-Füll - Regel (Skip & Fill) 

 
und machen Weiter. 
 
Die Regel wird beim Verlassen der in folgender Dialogbox festgelegten Fragen ausgeführt: 



 
 

AWS.DE.2 : 30. Mai 2005 28 
 

Fragebogendesign und Datenerfassung mit dem Data Entry Builder 4.0 
 

 
Jeder Frage kann nur eine Sprung-und-Füll-Regel zugeordnet werden. 
 
Im nächsten Schritt ist zunächst die Sprungbedingung unter Bezug auf Variablenausprägungen zu formu-
lieren: 

 
Gehen Sie folgendermaßen vor, um unsere relativ simple Bedingung zu formulieren. 

• Wählen Sie die Variable WIEOFT aus der zuständigen Liste. 
• Bei den Vergleichsoperatoren bietet Data Entry eine reichhaltige Auswahl. Verwenden Sie bitte den 

Identitätsoperator ==, um Personen mit einem bestimmten WIEOFT -Wert ansprechen zu können. 
• Tragen Sie den Wert 1 (steht für Nie) in das Kombinationsfeld Value(s) ein. 
In dem großen Textfeld innerhalb des If-Rahmens erscheint die zu unserer Bedingung gehörende JScript-
Syntax, wobei allerdings ein direktes Editieren hier nicht vorgesehen und auch nicht sinnvoll ist. 
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Nachdem wird den Wenn-Teil unserer Sprung-und-Füll - Regel erklärt haben, vereinbaren wir nun die 
erste Aktion des Dann-Teils. Starten Sie über den Schalter Fill Values die Dialogbox Fill when Ex-
pression is True: 

 
Tragen Sie für die alphanumerische (!) Variable ZIEL den Ersatzwert nicht anwendbar ein, tragen Sie für 
die numerische Variable ALTER den Ersatzwert 888 ein ( = benutzerdefinierter Missing Values – Indika-
tor), und machen Sie weiter mit Continue. 
 
Zurück in der Dialogbox Rule Wizard – Skip & Fill Rule starten wir über den Schalter Skip to a 
Question die Dialogbox zur Vereinbarung des Sprungziels: 

 
Die Spezifikation des Sprungziels erfolgt nicht über Variablen, sondern über Fragen, d.h. über Objekte 
auf den Erfassungsformularen. Nötigenfalls können Sie im Formularfenster über die Eigenschaftsdialog-
box den Namen des anzuspringenden Objektes ermitteln. 
 
Verlassen Sie das Skip-Fenster mit Continue und den Regel-Assistenten mit Fertigstellen. 
 
Im Builder-Fenster erscheint unsere Regel nach View > Rules unter dem Namen Form1_WieOft: 
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Regeln vom Typ Skip & Fill werden also offenbar nach dem Ausgangspunkt des Sprungs benannt. 
Zur Nachbearbeitung einer Regel kann per Doppelklick auf ihren Namen der Skripteditor gestartet wer-
den (vgl. Abschnitt 6.4): 

 
 
Offenbar ignoriert Data Entry eine Sprung-und-Füll - Regel, wenn die Bedingung auf Grund einer 
voreingestellten Variablenausprägung erfüllt ist, z.B.: 
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6 Weitere Optionen von Data Entry 
In diesem Abschnitt sollen einige weitere Optionen von Data Entry kurz erwähnt werden. 

6.1 Auto-Create 
Data Entry kann zu einer vorhandenen SPSS-Datendatei automatisch ein Formular erstellen, das zur Er-
fassung im Tabellenmodus optimiert ist. Beim Öffnen einer SAV-Datei, die noch ohne Data Entry – Er-
weiterungen ist, erscheint folgende Dialogbox mit der empfehlenswerten Option, für alle Variablen Text-
eingabefelder zu erzeugen: 

 
Anschließend kann man sofort mit der Datenerfassung beginnen, z.B.: 

 
Selbstverständlich ist auch den Formulareingabemodus nutzbar: 

 
 

6.2 AutoTab 
Bei einem komplett aus Texteingabefeldern bestehenden Formular ist der per 

Data > AutoTab 
zu aktivierende AutoTab-Modus sehr attraktiv. In diesem Erfassungsmodus wechselt Data Entry nach 
einer erkennbar vollständigen Dateneingabe automatisch zur nächsten Variablen, so dass z.B. bei einstel-
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ligen Variablen ein einziger Tastendruck genügt. Man spart also eine große Zahl von Tabulator-
Tastenschlägen bzw. äquivalenten Mausklicks. 
Um ein optimales AutoTab-Verhalten zu erreichen, muss bei allen Variablen die Feldbreite korrekt ge-
setzt werden, z.B. bei einer einstelligen numerischen Variablen: 

 
 

6.3 Bibliothek mit Standardfragen 
Über den Menübefehl 

Edit > Question Library 
erreicht man eine Bibliothek mit Standardfragen (leider nur in englischer Sprache), die sich sofort in ei-
gene Formulare übernehmen lassen: 

 
 



 
 

AWS.DE.2 : 30. Mai 2005 33 
 

Fragebogendesign und Datenerfassung mit dem Data Entry Builder 4.0 
 

6.4 JScript-Entwicklungsumgebung 
Data Entry unterstützt für Plausibilitätskontrollen und Filterfragen in JScript1 verfasste Regeln und Pro-
zeduren, wobei erstere per Variable Properties - Dialog oder per Regel-Assistent erzeugt werden. Zum 
Erstellen von Prozeduren sowie zum Ändern der Regeln steht über 

Rules > Rule Scripts 
eine JScript-Programmierumgebung mit Editor, Objekt-Browser (aus dem Editor per View > Objects 
zu starten) und weiteren Werkzeugen zur Verfügung, z.B.: 

 
 

                                                 
1 Dies ist Microsofts Variante der objektorientierten Skriptsprache JavaScript, die ursprünglich als Makrosprache für den 

WebBrowser Nescape entwickelt wurde, und die mittlerweile in vielen Softwareprodukten für Dynamik und Interaktivität 
sorgt. 
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